WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Clean URLs with Custom Content Type Manager (7 posts)

  1. foochuck
    Member
    Posted 1 year ago #

    I'm using the Custom Content Type Manager plugin found at: http://code.google.com/p/wordpress-custom-content-type-manager/

    The plugin works great, however I'm trying to display clean URLs on my site. Below is a sample of a URL for my "celebrities" content type. The URL isn't clean at all, however my site's Permalinks are set to use "month and name"

    Sample content type URL: mydomain.com/?post_type=celebrities&p=218

    Does anyone know how to establish clean URLs with this plugin?

  2. David Choi
    Member
    Posted 1 year ago #

  3. fireproofsocks
    Member
    Posted 1 year ago #

    It's probably not the "Flush Permalink Rules" setting, it's probably just the URL settings for your post-type. Remember: WordPress' permalink settings are not global. You have to set them up for each post-type as you create it. In the manager, head to the CCTM menu, edit your post-type, and inspect the "URLs" tab.

    If WordPress' limitations and caveats on URLs drives you insane, then I would urge you to look at MODx: its handling of URLs is much more sensible.

  4. foochuck
    Member
    Posted 1 year ago #

    I was able to update the URL w/ CCTM permalinks (changed permalink action to /%POSTNAME%/). The URLs updated, however when I then went to those pages, I keep getting a page not found error. When I went back and changed permalink action to off, linking to the pages worked, however the URLs were no longer clean. Also tried clearing the CCTM cache, but it didn't fix the page not found issue.

  5. fireproofsocks
    Member
    Posted 1 year ago #

    You can see why I hate WordPress' handling of URLs: it's painfully bad. This is nearly impossible for me to troubleshoot because the cause could be your server setup (e.g. .htaccess file not setup correctly) or conflicting plugins. I would test this first with a regular post to ensure that permalinks are working for built-in posts/pages, and then if that succeeds, try viewing a newly created custom post (WP may not update pre-existing URL mappings in the database). Be sure to disable all other plugins while trying this because sometimes other plugins mangle the filters meant to ensure this behavior works properly, and make sure you're using the most recent version of the CCTM (0.9.6.7 -- the WP repo has failed to pick up and distribute a few versions for some sites).

  6. foochuck
    Member
    Posted 1 year ago #

    Thanks @fireproofsocks - your post gave me an idea for the fix.

    I went back into CCTM and set the permalink - same issue as before.

    However this time, I did something else that I normally need to do which helps reset htaccess / permalinks. I went to the main WP permalinks page in settings, and switched the permalinks back to default, saved, and then I put it back to month and name.

    This help push through the other permalink updates from CCTM and now everything is working as needed. Thanks for your help and I hope this post assists someone else down the line...

  7. fireproofsocks
    Member
    Posted 1 year ago #

    Thanks for sharing! I bet the changing of the WP permalink settings triggered the rows in wp_posts to be updated.

    I just noticed that this was in the general WordPress forum -- best to post these in the CCTM's support forum, otherwise I may not see them.

Topic Closed

This topic has been closed to new replies.

About this Topic