WordPress.org

Ready to get started?Download WordPress

Forums

Tweet Blender
class-json error (16 posts)

  1. gaswirth
    Member
    Posted 3 years ago #

    Hey all,

    Just upgraded to WP 3.2, and immediately got an error with TweetBlender. This shows up where the widget used to load properly:

    require_once(/home/viiadmin/beta.vii-designs.com/harlemlanes/wp-includes/class-json.php) [function.require-once]: failed to open stream: No such file or directory in /home/viiadmin/beta.vii-designs.com/harlemlanes/wp-content/plugins/tweet-blender/lib/lib.php on line 509

    Any help would be appreciated!!! Thanks!

  2. 6clicks
    Member
    Posted 3 years ago #

    same error for me: http://4fronts.com

  3. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    require_once(/home/viiadmin/beta.vii-designs.com/harlemlanes/wp-includes/class-json.php) [function.require-once]: failed to open stream: No such file or directory in /home/viiadmin/beta.vii-designs.com/harlemlanes/wp-content/plugins/tweet-blender/lib/lib.php on line 509

    You'll need to disable the Tweet Blender plugin by renaming, or deleting the plugins folder. You can do this by using FTP or by using your hosts control panel's file manager.

    Once you rename the plugin folder, you'll be able to access the WordPress admin again, from there you can check to see if there's any updates available.

  4. wearebase
    Member
    Posted 3 years ago #

    Kirill,

    Same here man, it seem rather upset with the new version;

    Warning: require_once(D:\xampp\htdocs\live\bca/wp-includes/class-json.php) [function.require-once]: failed to open stream: No such file or directory in D:\xampp\htdocs\live\bca\wp-content\plugins\tweet-blender\lib\lib.php on line 509

    Have rolled back and will hold out updating any further sites.

    Thanks Kirill,

    - Matt

  5. Tweet Blender says it's working on a 3.2-compatible fix to be released later today: http://twitter.com/tweetblender

  6. 6clicks
    Member
    Posted 3 years ago #

    you can download the fix via twitter! http://twitter.com/tweetblender

  7. Peter Ould
    Member
    Posted 3 years ago #

    I get this error trying to activate version 3.3.11 on WP 3.2:

    Fatal error: Cannot redeclare class Services_JSON in /var/www/vhosts/peter-ould.net/httpdocs/wp-content/plugins/tweet-blender/lib/JSON.php on line 116

  8. theworld365
    Member
    Posted 3 years ago #

    I get the same error as Peter Ould.

    Fatal error: Cannot redeclare class Services_JSON in /.../wp-content/plugins/tweet-blender/lib/JSON.php on line 116

  9. Anja Fokker
    Vertaalteam WordPress NL
    Posted 3 years ago #

    Have you the plugin Tweetblender activated on your WordPress version 3.2, you will see that it will give an error. This is because the class-json.php file has been removed from the official core files of WordPress (version 3.2).
    Solution: Copy from WordPress 3.1.4 /wp-includes the file class-json.php to /wp-includes version 3.2 and you will see that the plugin Tweetblender works again (it works for me).

  10. Peter Ould
    Member
    Posted 3 years ago #

    I tried that Anja but it made no difference

  11. Anja Fokker
    Vertaalteam WordPress NL
    Posted 3 years ago #

    @Peter Ould: I only use the widget, see it on one of my testsites:
    http://werkgroepen.net/wordpressmu/twentyten/

  12. theworld365
    Member
    Posted 3 years ago #

    Yeah, I tried placing class-json.php .../wp-includes and it still didn't work.

    When I tried activating the plugin I got the same error as before.
    Also, I'm using a set of 3 widgets and didn't make any changes to posts, code, etc. Simply the widgets.

  13. theworld365
    Member
    Posted 3 years ago #

    Is there a cache associated with this plugin... Maybe cleaning the cache would fix it after putting the old class-json.php in the includes dir.

    I'm not using any caching plugins but other plugins have their own cache or tables that can be cleaned when issues like this happen.

  14. kirilln
    Member
    Plugin Author

    Posted 3 years ago #

    @Peter Ould: Found the bug. Will be fixed in 3.3.12 tonight

  15. Peter Ould
    Member
    Posted 3 years ago #

    Kirilln,

    You super-star. Well done!

  16. theworld365
    Member
    Posted 3 years ago #

    Thanks Kirill. You're the man!
    My tweets on #photography #travel #pets and #adventures are working again at TheWorld365.com

    Much appreciated!!

    Nuno

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic