WordPress.org

Ready to get started?Download WordPress

Forums

class-IXR.php Error in WP2.0 (4 posts)

  1. plainsman
    Member
    Posted 8 years ago #

    With the latest download of WP2.0 I am receiving this error when editing a post.

    Fatal error: Call to undefined function: xml_parser_create() in /htdocs/www/dir-name/wp-includes/class-IXR.php on line 144

    The initial writing and posting of something works fine. It is only when editing the post that I receive this error. Hmm?

    Truth be told, I also received the error with the download from 2 days ago, too. But, I don't know if the download has changed since then.

    I have searched the support forum and used Google site search. The only references I found to this were relating to the old 1.5 virus scare. Nothing about WP2.0 and this latest error.

    I also waited a few days to download a fresh version to see if it resolved the issue. But, it has not.

    Any ideas? Thank you!

  2. plainsman
    Member
    Posted 8 years ago #

    I was hoping to hear from someone on this, but I guess it is an isolated case? Has anyone seen this before, please?

  3. pcomfort
    Member
    Posted 8 years ago #

    Yes, I now have the same issue. I just upgraded to PHP5 and suspect this is part of the problem. Previously I have had no issue posting or editing with PHP4.

  4. cropley
    Member
    Posted 7 years ago #

    I've recently upgraded to 2.0.2 and have come up against an error related to class-IXR.php when publishing - not when saving or save and continue editing.

    Even though the error page displayed, on inspecting the site, the post was up. However, these posts included links to MP3 files which had usually been automatically detected and converted into enclosures. This seemed to be the sticking point that fired the error.

    After having a quick look at the code, I tried, as a workaround, running the class-IXR file from the previous installation. I believe it was the call to the IXR_client class that was breaking, which I discovered wasn't referenced in the new iteration of the class-IXR.php file.

    It's working fine now but I'm a little concerned that there might be some special updates in that file for 2.0.2 that may have been affected by reverting.

Topic Closed

This topic has been closed to new replies.

About this Topic