WordPress.org

Ready to get started?Download WordPress

Forums

Magic Fields 2 Toolkit
[resolved] Class 'alt_related_type_field' not found error on wordpress 3.6 (5 posts)

  1. Zihad Tarafdar
    Member
    Posted 10 months ago #

    Hello,

    After upgrading to wordpress version 3.6 I am getting this error with magic fields 2 toolkit when I am trying to edit or add new custom post type where alt_related_type field is used:

    Fatal error: Class 'alt_related_type_field' not found in \wp-content\plugins\magic-fields-2\admin\mf_post.php on line 425.

    I am using magic fields 2 version 2.1

    http://wordpress.org/plugins/magic-fields-2-toolkit/

  2. Magenta Cuda
    Member
    Plugin Author

    Posted 10 months ago #

    I was not able to duplicate this problem when upgrading to WordPress 3.6.1. However, I was able to to duplicate this exact problem when upgrading to Magic Fields 2.2. Did you simultaneously upgrade to Magic Fields 2.2?

    Since, Alt Related Type, Alt Textbox and Alt Dropdown must be enabled after Magic Fields 2 is installed or re-installed a way to fix this problem is to disable Alt Related Type, Alt Textbox and Alt Dropdown (followed by a Save Changes) then re-enable them (again followed by a Save Changes).

    Incidentally, Alt Audio is implemented differently and the above is not necessary. Also, Alt Audio causes problems (see AJAX scripts fail from whitespace after ?> in magic-fields-2-alt-get-audio.php) and I would disable it unless you make the change suggested in that article.

    If you did not simultaneously upgrade to Magic Fields 2.2 then this explanation is not valid and would appreciate you letting me know.

  3. Zihad Tarafdar
    Member
    Posted 10 months ago #

    thanks for the response! yes I think upgrading to magic fields 2.2 created the problem. I will let you know the result after applying your solution. btw, Is it somehow possible to make the plugin work in php 5.3+ version? I am not being able to use it in one of my clients server where 5.4+ version is not available. thanks again

  4. Magenta Cuda
    Member
    Plugin Author

    Posted 10 months ago #

    Although I don't advertise this I have made an effort to be compatible with 5.3 but not anything older. My documentation says 5.4 because almost all of my testing is done on 5.4 but I think it will work on 5.3 but not anything older. One user has told me it works on 5.3 but I am reluctant to claim it works on 5.3 based on one report.

  5. Zihad Tarafdar
    Member
    Posted 10 months ago #

    yes, it seems to work on 5.3+ as well. your solution also working fine. thanks for the help, buddy. cheers

Reply

You must log in to post.

About this Plugin

About this Topic