WordPress.org

Ready to get started?Download WordPress

Forums

WP-Ajaxify-Comments
[resolved] CKEditor disappears after posting comment (6 posts)

  1. itsramon
    Member
    Posted 1 year ago #

    Hi,

    I use the CKEditor For WordPress plugin 4.0 (also used in the comment form) along with WP-Ajaxify-Comments 0.9.0.

    When posting the comment, CKEditor disappears and the default textarea shows up again.

    Could you please take a look at this?

    Thank you!
    Ramon.

    http://wordpress.org/extend/plugins/wp-ajaxify-comments/

  2. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your comment.

    You can try on of the following "After update comments" setting

    CKEDITOR.instances[ckeditorSettings.textarea_id].destroy(true);
    ckeditorOn();

    or

    CKEDITOR.instances[ckeditorSettings.textarea_id].destroy(true);
    CKEDITOR.replace(ckeditorSettings.textarea_id,
    ckeditorSettings.configuration);
    var labelObj = jQuery('#'+ckeditorSettings.textarea_id).prev('label');
    if (labelObj){
       labelObj.hide();
    }

    This settings solved CKEditor problems with the Wp-rich-comments. Please leave me a message if this does not work with your CKEditor plugin and I will take a closer look.

    Hope this helps...

  3. itsramon
    Member
    Posted 1 year ago #

    Hi,

    Thanks for your quick response.
    Unfortunately, both options didn't work...
    They both result in a Javascript error:

    Error: TypeError: c is null
    Source File: [mydomain]/wp-content/plugins/ckeditor-for-wordpress/ckeditor/ckeditor.js?t=CBDD&ver=3.2.1
    Line: 712

    Thanks!

  4. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Please try the following settings:

    'OnBeforeUpdateComments' callback
    ckeditorOff();

    'OnAfterUpdateComments' callback
    ckeditorOn();

    Hope this helps...

  5. itsramon
    Member
    Posted 1 year ago #

    Yes! That did the trick!

    Thanks :-)

  6. janjonas
    Member
    Plugin Author

    Posted 1 year ago #

    Great! Thanks for your feedback...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic