WordPress.org

Ready to get started?Download WordPress

Forums

Related Links by Contextly
[resolved] [closed] Choose related search doesn't work and thumbnails aren't right (12 posts)

  1. Nomago
    Member
    Posted 5 months ago #

    For some reason when I go to choose related posts, I get nothing from my site when I search, even if I search for exact titles.

    The other thing is that the thumbnails the Related or You Might Like shows is random for posts, and some posts it doesn't show any but the default Contextly image. How does the algorithm pick which pictures to show from a post? Can you not just have it show the featured image as the thumbnail?

    https://wordpress.org/plugins/contextly-related-links/

  2. rsingel
    Member
    Plugin Author

    Posted 5 months ago #

    HI Nomago -

    Could you tell me what your site is so I can look into the photo issue?

    Contextly does rely on featured images, but the most important thing we look for is metadata, whether that's OpenGraph or Schema info. Depending on how long ago you installed the plugin (minutes or hours, some of this may be a caching problem).

    Can you email me at info@contextly.com with some links?

    I can also check what's going on with search.

    Thanks,

    RS

  3. Nomago
    Member
    Posted 5 months ago #

    sent you an email, thanks

  4. rsingel
    Member
    Plugin Author

    Posted 5 months ago #

    Nomago,

    Sorry but I didn't see an email from you. Can you re-send to [my first name] at contextly.com?

    Thanks,

    RS

  5. bfcmaintenance
    Member
    Posted 4 months ago #

    I am having this exact same problem. I installed the plugin about a month ago and it only pulls the default thumbnail (site logo) and doesn't find any of the articles when I try to select which related post should appear from within a post.

    You can see a sample post here: http://betablog.benfredaconsulting.com/restore-funding-for-hiv-housing/5090

  6. rsingel
    Member
    Plugin Author

    Posted 4 months ago #

    Hi Ben,

    I put in a request for this. I suspect what's happening is that the image parser is incorrectly ignoring your featured images due to their size (150x150). That's actually a perfectly fine size, but we had some logic before that ignored them if they were below our largest size images (220x125).

    We'll reprocess the images.

    As for the search, that's a known bug for smaller sites. We have a plan to make sure every search works, but we don't have a date for that just yet.

    If you could send me some sample searches that don't give the results you are looking for, that would be very helpful. You can email those to info@contextly.com

    Best,

    RS

  7. bfcmaintenance
    Member
    Posted 4 months ago #

    Thanks for your quick response. This is actually just a development version of the site we're hoping to put this up on, so once I move the plugin over to the live site is there anything I can do to process the images over there (betablog.org)?

    For the search results when choosing a related post, the only post I can get to show up is "A Guide to Clinical Trials PART I:"
    Most searches produce zero results (for example "virus," "aging" or any words that aren't in the "A Guide to Clinical Trials..." post. I don't think all of the posts on the site are indexed because it seems like the same 10 or so are showing up as related posts whether they are related or not.

    Thanks again for your help, it's much appreciated.

  8. rsingel
    Member
    Plugin Author

    Posted 4 months ago #

    You shouldn't have to do anything to get the images right. It's clearly something we're just missing and I'm 99% sure it's just a bug in the script about the size of the image.

    And the dev blog part totally makes sense. Try the search now -- I switched your default search to the live blog and I *think* you'll get much better results. (When you search now, you'll see two tabs - one live, one dev).

    As for pushing it live, let us make sure we don't have that image bug before you switch over. We should have an answer/fix by EOD Monday.

    Let me know if the new search works any better. I'm ryan ataround contextly.com

    Ryan

  9. rsingel
    Member
    Plugin Author

    Posted 4 months ago #

    Hi,

    The images seem to be correct now. Let me know if there's still a problem with the search.

    Best -

    RS

  10. rsingel
    Member
    Plugin Author

    Posted 3 months ago #

    Everything seems to be working well on the site. I'm closing this ticket.

    Thanks!

    RS

  11. MNadmin37
    Member
    Posted 3 months ago #

    Having a similar problem with "Related Posts." The thumbnails have stopped appearing at the end of my blog posts. I uploaded a generic thumbnail for my blog to go in their place. But, I would prefer if the feature thumbnails from the actual blog posts would reappear. Here is a link to a blog post; http://www.michaelnimmons.com/?p=1912

  12. esmi
    Forum Moderator
    Posted 2 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this 2 month old, resolved, topic as it references an older version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.