WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] CHMOD not working for Upload Directory (6 posts)

  1. martini
    Member
    Posted 9 years ago #

    I have gotten WordPress working perfectly save for one feature -- upload. I click on that link only to find the following message:

    "It doesn't look like you can use the file upload feature at this time because the directory you have specified (/home/public_html/pwrbtn/post-images) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos."

    I have set the directory to 777 and also tried 776 both through the browser FTP program from my CPANEL and also through GlobalSCAPE's CuteFTP program.

    Any ideas? Thanks in advance!

  2. Class
    Member
    Posted 9 years ago #

    Are you sure WP are looking for the correct folder?

  3. martini
    Member
    Posted 9 years ago #

    Yes, I have confirmed in the options that it is the same folder. Is there another way?

  4. Class
    Member
    Posted 9 years ago #

    I only know how to set permissions in a shell I'm afraid.

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Try a different directory - if nothing else just to check and be totally sure that you and wp are looking at the same thing.

    From experience here, this sort of thing happens only when the user and wp are looking at different things.

    Look at the Upload options - you have to supply a path AND a url. Check carefully.

  6. forbes
    Member
    Posted 9 years ago #

    Also, make sure that WP has execute permission on the parent directory (/home/public_html/pwrbtn). Some flavors of Unix won't allow you to access a directory unless you have execute permissions on the parent(s).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.