WordPress.org

Ready to get started?Download WordPress

Forums

Chinese Permalinks not working ("It's embarrassing message (2 posts)

  1. erick_paper
    Member
    Posted 2 years ago #

    Hi.

    Fresh install of WordPress. No plugin enabled.

    Permalink structure:

    /%category%/%postname%

    When I click on any single post with this permalink structure, it shows me an error:

    This is somewhat embarrassing, isn’t it?
    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

    The issue is that it's so unpredictable.

    Category URL is ok even if category name contains Chinese:
    http://ubeni.org/category/杂项/
    http://ubeni.org/杂项/ (works even without "category/")

    Single post NOT ok:
    http://ubeni.org/杂项/穿得美美滴慢跑/

    Tag link NOT ok:
    http://ubeni.org/tag/服装/

    Tag link if ok if in English!:
    http://ubeni.org/tag/tgc/

    Why this sporadic problem with utf-8 characters in the permalink? I thought this would be normal by now in version 3.3.1 of the software!?

    Platform is Apache/PHP latest.

    I definitely need this permalink structure as it makes most semantic sense. It works on my other blogs such as this Japanese one: http://fujikosuda.com/worklife-jp/ワークスタイル/仕事の将来/サステナビリティ活動の具体的な、測定できる目

    So what's the problem?

    Would appreciate any thoughts, thanks.

    [No bumping - especially after only 30 minutes. If it's that urgent, consider hiring someone.]

  2. liuxyon
    Member
    Posted 1 year ago #

    WP3.4.2 still has no fix this support chinese url and upload chinese name files.

Topic Closed

This topic has been closed to new replies.

About this Topic