WordPress.org

Ready to get started?Download WordPress

Forums

Google Forms
[resolved] Chinese? (15 posts)

  1. pridm001
    Member
    Posted 1 year ago #

    I created a form and linked to it with your plugin, but I'm having trouble getting it to appear without Chinese characters.

    http://www.woodchuckcommunityfarm.com/become-a-member

    Per your suggestion to someone previously I tried to force it to English by including &hl=en in my form URL but it started returning a paragraph in Chinese.

    Thank you

    http://wordpress.org/extend/plugins/wpgform/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    This seems to happen periodically but will usually go away in a day or two. It has something to do with how Google serves content from their servers around the world.

    I am surprised the &hl=en didn't work, it usually does. Did you enter it using the WordPress text or visual editor? You may want to double check that the ampersand didn't get turned into it's HTML entity code by looking at the post (or page) the form is on with the plain text editor.

  3. pridm001
    Member
    Posted 1 year ago #

    Hi, thank you for replying so quickly!

    The plain text editor shows this: [gform form='https://docs.google.com/forms/d/1jsvfXOZN5qlA0Ru3rTFYRGu-zzBA6666NduxWBhBJTo/viewform&amp&hl=en']

    and my site looks like this: http://www.woodchuckcommunityfarm.com/become-a-member

    If it will resolve it's self in a few days then I won't worry about it too much.

  4. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    See of changing your shortcode to this helps:

    [gform form='https://docs.google.com/forms/d/1jsvfXOZN5qlA0Ru3rTFYRGu-zzBA6666NduxWBhBJTo/viewform&hl=en']

    Note that I removed &amp near the end. I suspect that is your problem.

  5. pridm001
    Member
    Posted 1 year ago #

    I actually thought of that seconds after I posted it and tried it. Didn't work :(. I'll just hope it resolves its self. Thanks for your help!

  6. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I was going to try it on my site but Google tells me that document doesn't exist.

  7. pridm001
    Member
    Posted 1 year ago #

  8. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I do not see the Chinese characters when I put your form on my site for testing.

    It looks like the new URL format Google is using for Forms does not accept the same parameters the old URL format (ie &hl=en). If someone can figure out a way to do that, I'd appreciate it but my Google search yielded nothing.

    However, you may want to try setting the language for your Google Docs to English per this Help Page on Google. When I did it on my Drive, I did not have a specific language set.

  9. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I think I have a solution for this problem. It is working on another site that was having the same issue but in German. I have a new beta release out today as well as a post explaining what happens and how I fixed it.

  10. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I have another beta update to account for language issues. Google has added some more default text that is subject to being served up in a foreign language. This update provides settings for several more fields that can be overridden.

  11. Manijero.com
    Member
    Posted 1 year ago #

    Hi,
    I have the same problem. My hosting services are located in Germany and there was no way to show label in Spanish(what I was looking for). Finaly I had found a solution. Add to the url of your Google form <?hl=es> for Spanish.

    Using your example:

    [gform form='https://docs.google.com/forms/d/1jsvfXOZN5qlA0Ru3rTFYRGu-zzBA6666NduxWBhBJTo/?hl=en']

  12. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    This is great news that the language parameter has returned. This must have happened in the last day or so because I've been chasing it for several days and it wasn't working. Looks like the new override functionality I just completed is no longer necessary although I will leave it in in case someone needs it.

  13. pridm001
    Member
    Posted 1 year ago #

    This isn't working for me?

    [gform form='https://docs.google.com/forms/d/1jsvfXOZN5qlA0Ru3rTFYRGu-zzBA6666NduxWBhBJTo/?hl=en']

  14. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    What isn't working?

    I was able to use ?hl=fr parameter to cause the buttons and other text to appear in French. You can see it on my site here.

    In fact, I put it on the page twice, once in French and once in English using both the wpgform shortcode (for the French one) and the exact gform short code (for the English one) you posted above.

  15. Mike Walsh
    Member
    Plugin Author

    Posted 1 year ago #

    I am going to mark this resolved. In the testing I've done, using the &hl=XX (where XX is the language code e.g. "fr" for French, "en" for English, etc.) on the old Google Forms URLs or ?hl=XX (where XX is the language code e.g. "fr" for French, "en" for English, etc.) on the new Google Forms URLs appears to address the problems where the form is served with buttons and text in an undesired language.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic