WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Child theme won't overwrite Parent (7 posts)

  1. moynihan22a
    Member
    Posted 9 months ago #

    Hi, I am hoping to get some specific help, I have read all the other postings on this topic. It is possible I am just missing a comma or something, but nothing has worked.
    I just switched to responsive, and updated to 3.5.2. I started a child theme using the directions on the wordpress codex. I had been changing my old theme (Hero) directly, but decided to do the recommended path of using a child theme when I switched to Responsive.
    Here is what I have in the new stylesheet. I am 90% sure it is in the correct folder and is activated.
    /*
    Theme Name: responsive child
    Author: Alison Moynihan
    Template: responsive
    */
    @import url('../responsive/style.css');
    /*edits*/
    body {
    color:#0b260b;
    }
    .widget-wrapper {
    background-color: #ceeeff;
    border: 2px solid #95d95d;
    }

    Thank you for taking a look.

  2. GraphicSmart - Wayne Strickland
    Member
    Posted 9 months ago #

    Posting a link to your site where you are having the issue(s)... helps others to take a look. Thanks!

  3. esmi
    Theme Diva & Forum Moderator
    Posted 9 months ago #

    As per the theme developer's request, please try posting on the theme's dedicated forum: http://cyberchimps.com/forum/free/responsive/

  4. moynihan22a
    Member
    Posted 9 months ago #

    Thanks, I will try the other site, but I will leave this open for a little bit in case anyone here can help.
    site is still being developed but here is the temp url
    http://50.87.188.15/testing/

    I can add the css to the theme options and it works but that is not the same as a child theme and so it will be lost during upgrades correct?
    Thanks for the quick response!

  5. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    No, custom CSS won't be overwritten - that's the purpose of it being a theme option :).

  6. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    You don't have a child theme activated on that site. Did you activate it?

  7. moynihan22a
    Member
    Posted 9 months ago #

    Thanks I will just do that and forget about trying to get the child theme to work!

Reply

You must log in to post.

About this Topic