WordPress.org

Ready to get started?Download WordPress

Forums

Expound
Child Theme won't install (9 posts)

  1. angopop
    Member
    Posted 6 months ago #

    Hello, I seem to have problems installing a child theme for Expound. I'm new to this, so here is what I'm doing so far:

    I created a folder called: "expound-child"
    Inside is a document called: "style.css"

    Here is what is in the "style.css" doc:

    /*
    Theme Name: Expound Child
    Theme URI: http://wordpress.org/themes/expound
    Author URI: http://asmmastering.com
    Description: A child theme of the expound theme created for ilase.co.uk
    Template: expound
    Version 2.0.1
    */
    @import url("../expound/style.css");

    */

    I've tried both using WordPress "Add New Theme" (zipping the folder) and Cyberduck to FTP the folder or just the style.css to the proper folder.

    But when I go to install the child theme I get this:
    Destination folder already exists.
    Theme install failed.
    Theme installed successfully.

    On my WP admin Themes page at the bottom is noted this: Expound Child\ The parent theme is missing. Please install the "expound\" parent theme.

    Previously it was stating I was missing the php.index page, so the failure problem seems to change.

    Any help?

    Thanks!

  2. Andrew
    Forum Moderator
    Posted 6 months ago #

    Where did you create your Child Theme (in which directory)?

  3. angopop
    Member
    Posted 6 months ago #

    I placed it in the themes directory, the same one where expound and twentytwelve and the others are.

  4. DMBarber
    Member
    Posted 6 months ago #

    Silly question: do you also have the Expound theme installed?

  5. Tareq
    Member
    Posted 6 months ago #

    On my WP admin Themes page at the bottom is noted this: Expound Child\ The parent theme is missing. Please install the "expound\" parent theme.

    The reason you are getting this error is because the Expound base theme is not installed. The parent theme must be installed for the child theme to inherit the code. If it is installed, uninstall Expound and Expound child and do the following:

    Install Expound and then continue:

    Appearance -> Themes -> Add New -> (search for) Expound -> Install Theme -> Re-install Child Theme you made!

  6. angopop
    Member
    Posted 6 months ago #

    Yes, I did install expound, and it' working well, but I can try re-installing it, and then the child theme.

  7. Tareq
    Member
    Posted 6 months ago #

    If you do have trouble installing a child theme, use what I use:

    Orbisius Child Theme Creator - saves you hours!

  8. angopop
    Member
    Posted 6 months ago #

    Child Theme creator seems like a good idea ... tried it but it messed up my menu, even in the parent theme ... I'll go post on the site to see about resolving....

    Does anyone have any ideas why the child theme does not work ... the parent theme is installed and I believe the Child Theme was written correctly....

  9. angopop
    Member
    Posted 6 months ago #

    Fixed it ... Child Theme creator worked after some tweaking ... thanks, onto the next problem to resolve!

Reply

You must log in to post.

About this Theme

About this Topic