Ready to get started?Download WordPress


[resolved] Child theme template (11 posts)

  1. CaptainCrunch
    Posted 1 year ago #

    Hey there,

    first of all: Thank you so much for this amazing theme. I could play around with it's scalability and responsiveness all day :-)

    I was just wondering if there is anything I need to mind if creating my own page templates? I'm working on a child theme that is based on Blaskan and uploaded a page template in my child theme's folder (via Cyberduck). However, it doesn't show up in the pages dropdown?

    Probably a silly mistake or something I missed… Just asking. Any help appreciated…


  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

  3. CaptainCrunch
    Posted 1 year ago #

    well yes… I created a file, called it template_start.php and added the following code:

    Template Name: start

    I uploaded the file into my child theme's directory (that's what I also did with another child theme which was based on Thematic and it worked back then).

    I also tried to log in and out again, and also put the file in the parent theme's directory… However no success so far… What did I miss?

  4. Tarsem Singh
    Posted 1 year ago #

    Please disable the same theme once and active it again.

  5. alchymyth
    Forum Moderator
    Posted 1 year ago #

    what file name have you used?

    double check the file location;
    can you see the file in the list on the right, when you go to
    dashboard - appearance - editor, and select your child theme in the dropdown at the top?

    general troubleshooting:
    temporarily, try to deactivate all plugins to see if you can use the page template then;
    if yes, reactivate one plugin at a time to locate the interfering one.

    I just uploaded the theme, created a child theme;
    and I have no problems creating and using a page template (file name start-page.php) with the same top info within a child theme of blaskan.

  6. CaptainCrunch
    Posted 1 year ago #


    Switched themes — no success…

    But: template_start.php does appear in the right hand menu when I go to 'Appearance' > 'Editor'.

    I'm going to deactivate plugins now…

  7. CaptainCrunch
    Posted 1 year ago #

    So I turned off all plug-ins, switched themes, logged out and in again… still no success. There is obviously some silly thing I'm missing

  8. CaptainCrunch
    Posted 1 year ago #

    The weird part is: If I create a new page using the "Pages" > "Add new" tab, it'll show up in the 'Reading' section under 'Settings'. If I use Komodo and upload the file manually it won't. However it does appear in the appearance editor…

  9. CaptainCrunch
    Posted 1 year ago #

    I think I know what I did wrong. I expected my template to appear in the Pages tab on its own… But I have to create a new page in this menue and then select 'Page Attributes' > 'Template' — right?

  10. alchymyth
    Forum Moderator
    Posted 1 year ago #

    correct -

    well done ;-)

    I am so used to this that I didn't think of checking;
    if this is now working, please mark the topic as 'resolved' - thanks.

  11. CaptainCrunch
    Posted 1 year ago #

    Cheers :-)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic