WordPress.org

Ready to get started?Download WordPress

Forums

Child Theme not working properly (4 posts)

  1. fedestura
    Member
    Posted 1 month ago #

    Hi,

    I am trying to make a Child theme for my website http://www.retreatdiscounter.com. I am not very good in coding. I have tried following the steps mentioned here: http://codex.wordpress.org/Child_Themes but it doesn't seem to be working. When I activate my Child Theme I get the following error: "Cannot write cache folder. You may try setting the folder cache folder permission to 755 or 777 to solved this."

    Can anyone assist me on how to solve this problem?
    Thanks in advance for your help.
    Best regards,

    Freddie.

  2. MH Themes
    Member
    Posted 1 month ago #

    Hi Freddie,

    it seems there is a problem with the folder permissions on your server. You can use an FTP client to change the permissions: http://www.dummies.com/how-to/content/how-to-set-file-permissions-on-a-remote-ftp-site.html

    Your hosting company should also be able to help you with this.

    Regards,
    Michael

  3. pixellanguage
    Member
    Posted 1 month ago #

    Hi Freddie,

    Yes it seems permission issue but it is nothing to do with child theme process.

    Try one more time and delete already created child theme if you on server.

    And follow this 3 step in simple way:

    1) Create child theme directory

    2) make one style.css and add this /*
    Theme Name: Twenty Fourteen Child (It Should be Your Child theme name)
    Template: twentyfourteen (Your Template name)
    */

    @import url("../twentyfourteen/rtl.css"); (Your main theme css url)

    3) Create Screenshot.png in 640 * 480px

    Any problem let me know.

    Regards,
    Rajan

  4. fedestura
    Member
    Posted 1 month ago #

    Hi,

    Thanks to both of you for the help. I have used Filezilla to change the file permissions of the 'Cache' folder from 755 to 777.

    As well, I have done what Rajan advices me. I still receive the same message. I really don't know what to do.

    This is the code I have placed in my styles.css, maybe there's some missing:

    @charset "utf-8";
    /*
    Theme Name: Bazar Child
    Template: bazar
    */
    
    @import url("../bazar/rtl.css");

    Thanks again for all your help.
    Best regards,

    Freddie.

Reply

You must log in to post.

About this Topic