WordPress.org

Ready to get started?Download WordPress

Forums

Child theme creation on Lugada, hosted by 123-reg (7 posts)

  1. rachellucie
    Member
    Posted 2 years ago #

    Hi there,

    I am running into great problems with this whole thing.

    I have installed Lugada theme. I tried, several times to use the one-click child theme plugin on my site so that I could change fonts, colours, basic stuff.

    Whenever I activated the plugin to use create the child I got error:

    Warning: require_once(/websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lucadas-baby/include/theme-options.php) [function.require-once]: failed to open stream: No such file or directory in /websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lugada/functions.php on line 3
    
    Fatal error: require_once() [function.require]: Failed opening required '/websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lucadas-baby/include/theme-options.php' (include_path='.:/usr/local/php52/share/pear:/usr/local/php52/share/php') in /websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lugada/functions.php on line 3

    I then had to get 123-reg to remove it and start again. I gave up this plug-in as being flaky and followed instructions to make my own child.

    I am now using:

    /*
    Theme Name:     baby lugada
    Theme URI:      http://rachellucie.co.uk/blog
    Description:    my lugada edits
    Author:         Rachel Lucie Johns
    Author URI:     http://www.rachellucie.co.uk
    Template:       lugada
    Version:        1
    */
    
    @import url("../lugada/style.css");

    I used preview for the child, instead of activating it (I learnt something!) but I still get those errors for the preview:

    Warning: require_once(/websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/babylugada/include/theme-options.php) [function.require-once]: failed to open stream: No such file or directory in /websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lugada/functions.php on line 3
    
    Fatal error: require_once() [function.require]: Failed opening required '/websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/babylugada/include/theme-options.php' (include_path='.:/usr/share/pear:/usr/share/php') in /websites/123reg/LinuxPackage21/ra/ch/el/rachellucie.co.uk/public_html/blog/wp-content/themes/lugada/functions.php on line 3

    So, my question is - is this the theme, is it me, or is it 123-reg, somehow? I am grateful for any help :)

  2. rachellucie
    Member
    Posted 2 years ago #

    (also, I am not sure what 'backticks' are are they ''' as my code doesn't look right here?) < I now know what a backtick is, original post still stands.

  3. JarretC
    Member
    Posted 2 years ago #

    Looks to be an issue with a missing file. If you browse through your files (your host might provide a file manager) you would want to look in the /blog/wp-content/themes/babylugada/include/ directory and see if there is a theme-options.php file in there.

    In both errors, this file is reported missing or having the wrong URL to the file so you'll have to see if that file exists to make sure the error doesn't happen.

  4. rachellucie
    Member
    Posted 2 years ago #

    hi there,

    I have copied all the files from the original lugada into lugada child, including the folder that is in, with that file. This has made no difference.

    I can certainly see the file in both.

    thanks for your help, any more ideas (or what have I done wrong!)

  5. meowette
    Member
    Posted 1 year ago #

    Hey Rachel, were you able to fiure this out? I'm trying to create a child theme for Lugada too, and I'm getting the same error.

  6. kevinhaig
    Member
    Posted 1 year ago #

    The problem lies in functions.php.

    On lines 3,4, and 5 :

    require_once ( get_stylesheet_directory() . '/include/theme-options.php' );
    require_once ( get_stylesheet_directory() . '/include/breadcrumbs.php' );
    require_once ( get_stylesheet_directory() . '/include/widget.php' );

    should be :

    require_once ( get_template_directory() . '/include/theme-options.php' );
    require_once ( get_template_directory() . '/include/breadcrumbs.php' );
    require_once ( get_template_directory() . '/include/widget.php' );

    Perhaps the theme author should look at making the theme child friendly.
    I would ask them to check into it. Looks like a nice theme by the way.

  7. meowette
    Member
    Posted 1 year ago #

    That did the trick, thanks so much Kevin! I really appreciate it. :)

Topic Closed

This topic has been closed to new replies.

About this Topic