WordPress.org

Ready to get started?Download WordPress

Forums

Checkout Redirect not working (7 posts)

  1. bahbondo1
    Member
    Posted 5 months ago #

    I upgraded my WooCommerce to 2.1, and now get a funny redirect code after submission of credit card info.
    {"result":"failure","messages":"
    \n\t\t\t
    Action failed. Please refresh the page and retry.<\/li>\n\t\t\t
    Sorry, your session has expired. Return to homepage →<\/a><\/li>\n\t\t\t
    First Name<\/strong> is a required field.<\/li>\n\t\t\t
    Last Name<\/strong> is a required field.<\/li>\n\t\t\t
    Address<\/strong> is a required field.<\/li>\n\t\t\t
    Town\/City<\/strong> is a required field.<\/li>\n\t\t\t
    Postcode<\/strong> is a required field.<\/li>\n\t\t\t
    Country<\/strong> is a required field.<\/li>\n\t\t\t
    Email Address<\/strong> is a required field.<\/li>\n\t\t\t
    Phone<\/strong> is a required field.<\/li>\n\t<\/ul>","refresh":"false"}

    I understand that a Thank you page can solve this problem. Anyone care to walk me through it? Thanks!

  2. Chirag Vora
    Member
    Posted 5 months ago #

    Thank you page will not solve your problem.

    In WooCommerce 2.1 pages like thank you, Checkout->pay etc. are replaced by endpoints.

    Check for payment gateway plugin updates to take care of this.

  3. bahbondo1
    Member
    Posted 5 months ago #

    Thanks for the reply, I see no available updates for my payment gateway.

  4. Chirag Vora
    Member
    Posted 5 months ago #

    I guess you need to ask them for 2.1 compatibility

  5. dennis93q
    Member
    Posted 5 months ago #

    Is there any other way to do this? We are getting the same exact error message. The plugin will not be upgraded to support 2.1. The orders ARE going through, just throwing that ugly error afterwards.... Any workarounds at all for this???

  6. Chirag Vora
    Member
    Posted 5 months ago #

    get_permalink for the pay page is to be replaced with $order->get_checkout_payment_url( true );

    https://wordpress.org/support/topic/woocommerce-ccavenue-gateway-not-working?replies=25

  7. sanaullah929
    Member
    Posted 1 month ago #

    Hi,Create and new page named as "Thankyou" from admin-panel and put this short code in it [woocommerce_thankyou]
    than publish that page with default template
    than its works fine if it is not working than Go to woocommerece plugin >> setting >> pages
    than add thankyou page in thanks feild and save it than your issue will resolved.

    Sanaullah

Reply

You must log in to post.

About this Topic