WordPress.org

Ready to get started?Download WordPress

Forums

WP e-Commerce
[resolved] Checkout is not transferring to Paypal (11 posts)

  1. kangharp
    Member
    Posted 11 months ago #

    I am using WP E Commerce Version 3.8.11.1 and Word Press 3.5.1. The checkout link is not transferring me to PayPal to make the transaction. I am trying to use my sandbox account to complete a test transaction.

    Settings: IPN is set to Yes, and shipping details and address override are set to No. The user name is set to the business sandbox account as the facilitator.

    I've also contacted the host of my website, and they said everything is good on their end. So i'm not sure what the problem could be. I would greatly appreciate someone could help me out on this.

    http://gsmisland.com/ --->try checking out.

    -Thanks

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Justin Sainton
    Member
    Plugin Author

    Posted 11 months ago #

    I can't actually get to your checkout page - it seems to think it's the products-page.

    Can you try doing two things - first, go to your WP Admin and click on your Products Page and update it - don't make any changes, just update it.

    Then, go to Permalinks (Under Settings > Permalinks) - that will flush the permalinks.

  3. kangharp
    Member
    Posted 11 months ago #

    Thank you for the reply.

    I have updated my product page and went to Permalinks as well (I just pressed save in permalinks, if thats what you meant). Still nothing has changed. I went to the checkout page and realized (under page page attribute) that the parent page was Products Page. Is this correct?

    -Is there anything more I can try?

  4. Justin Sainton
    Member
    Plugin Author

    Posted 11 months ago #

    Yeah, that's fine for it to be there, that's how it is by default.

    If you'd like to send your WP and FTP credentials to me at justinsainton@gmail.com, I'd be happy to take a deeper look and see what I can do - if there's a core issue here, we obviously need to get a fix out for it.

  5. kangharp
    Member
    Posted 11 months ago #

    cool I sent you the links

  6. Justin Sainton
    Member
    Plugin Author

    Posted 11 months ago #

    You're all sorted out now!

    For anyone else that might have this issue - I believe there was another plugin activated at some point that caused a rewrite rule collision. Refreshing permalinks and deactivating then reactivating the plugin fixed it.

  7. kangharp
    Member
    Posted 11 months ago #

    Thanks!!!

  8. amberrenee01
    Member
    Posted 10 months ago #

    I am also having this issue. I've already refreshed the permalinks and deactivated and reactivated the WP e-commerce plugins, but I'm still having the same problem. I get to the page right before it's supposed to take you to paypal, then upon clicking it seems to just refresh the page. I've also confirmed the IPN option with my Paypal account. I was wondering if there are any other steps I might try.

  9. amberrenee01
    Member
    Posted 10 months ago #

    Ah I've figured it out! There's an option in the Store settings under Checkout to make the State option mandatory. Well, it seems that the state option doesn't show up or is being hidden in the form for some reason. Now, apparently this is supposed to give you an error message, but this error message seems to be hidden as well. I found the answer here: http://www.dreamdrivenweb.com/2010/04/21/wp-e-commerce-checkout-refresh-problem-solved/comment-page-1/ in case anyone else may be interested. :D

  10. tevans33
    Member
    Posted 10 months ago #

    I'm having a similar problem, I had to set up the direct pay that goes straight to paypal because it seems when I had the add ti cart function set up and it went to the cart the program body is too wide and hidding half of it under the sidebar. I can see the start of the words for tax and shipping but you can't see anything past their first letters, I'm guessing that the total button is tabbed over past them but can't see it or the checkout button.

    Is there a way to make this fit in web page body better.
    Here's my site:
    http://www.valleyofthekings3dfilms.com

  11. kangharp
    Member
    Posted 10 months ago #

    Hey guys the way I fixed all the problems was very simple, I deactivated and activated the plug in a couple times. After I did that it worked very well!

Reply

You must log in to post.

About this Plugin

About this Topic