WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Checkout Error during payment process (3 posts)

  1. cbenn595
    Member
    Posted 1 year ago #

    We have two client sites using WooCommerce with WooThemes (Whitelight & Canvas). Everything works fine until you get to the checkout page and complete the order. If it's a new customer not registered as an existing user and they create a new account during the checkout process, once they go to process the order a message appears on the same page saying "You do not have permission to edit this post".

    It does not redirect them to the thank you page, it does not capture their billing (customer info), and it does not process the order. It does however add them to the WP user database as a customer with email and password only.

    We've disabled/enabled all plugins, changed WooCommerce settings for checkout, and disabled/enabled SSL. None of which has fixed the issue.

    If I (admin) go to purchase a product on the site, the process works without error and everything is fine.

    Is there an issue with the code related to creating a new customer account to make a purchase or is there another setting somewhere that we are missing??

    Please help as we've been working on this issue ever since we upgraded to the new 2.0 version of WC.

    Referenced sites we are having the issues with:
    http://www.fivestarlandscaping.ca
    http://www.paramountlimousinecalgary.ca

    Thanks for your help.

    http://wordpress.org/extend/plugins/woocommerce/

  2. richerr
    Member
    Posted 9 months ago #

    I had the exact same problem and found yours too when i did a google search. However, i have now found a solution to the problem but i hope the same solution works for you.

    SOLUTION - Deactivate "EASY WP SEO" plugin, not alot of people use this plugin since it is a paid plugin, that is why you wont find too many people in google search results that are experiencing the exact same problem. I hope this works for you (if you do have the plugin installed).

    Lets leave a feedback for others who may be searching for a solution to the same problem

  3. cbenn595
    Member
    Posted 9 months ago #

    Thanks richerr for your feedback.

    Yes, I did have Easy WP SEO installed which very well could have been the issue.

    Since my original post here, we have updated to the latest version of WooCommerce Version 2.0.19 and now have not experienced the problem again.

    Thanks again for you input. Best of luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic