WordPress.org

Ready to get started?Download WordPress

Forums

Postie
[resolved] Checking for mail manually - no emails found (31 posts)

  1. phileasffogg
    Member
    Posted 1 year ago #

    postie doesn't find new mail anymore.

    after succesfully testing the config, running postie manually does not seem to work.
    i have configured postie with pop3. when hitting the run postie button, all i get is the message: Checking for mail manually. i have a bunch of new emails sitting in the inbox.

    also strange is, when entering the wrong password an testing the config, i do get an okay.

    how can i get postie to print out more debug information?

    thanks

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

  3. phileasffogg
    Member
    Posted 1 year ago #

    Okay, all i get is (no matter if the password is right or wrong):

    [17-Jan-2013 20:00:41 UTC] Postie: Error log: /home/httpd/vhosts/sime.li/httpdocs/wp-content/debug.log
    [17-Jan-2013 20:00:41 UTC] Postie: Postie is in /home/httpd/vhosts/sime.li/httpdocs/wp-content/plugins/postie
    [17-Jan-2013 20:00:41 UTC] Postie: iconv: yes
    [17-Jan-2013 20:00:41 UTC] Postie: imap <small>(required for subjects)</small>: yes
    [17-Jan-2013 20:00:41 UTC] Postie: GMT: 2013-01-17 20:00:41
    [17-Jan-2013 20:00:41 UTC] Postie: Current: 2013-01-17 20:00:41
    [17-Jan-2013 20:00:41 UTC] Postie: Sucessful POP3 connection on port 110
    [17-Jan-2013 20:00:45 UTC] Postie: Checking for mail manually

    anything else i can do to analyze?

    thanks

  4. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Please click Run Postie and report back your logs.

  5. phileasffogg
    Member
    Posted 1 year ago #

    this is what i get:

    [18-Jan-2013 20:53:06 UTC] Postie: Checking for mail manually
    [18-Jan-2013 20:53:06 UTC] Postie: wp_content_path: /home/httpd/vhosts/sime.li/httpdocs/wp-content

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    That is all? You should get at least

    [18-Jan-2013 21:54:41 UTC] Postie: Checking for mail manually
    [18-Jan-2013 21:54:41 UTC] Postie: wp_content_path: C:\source\postie\wp35\wp-content
    [18-Jan-2013 21:54:41 UTC] Postie: found filterPostie.php in wp-content
    [18-Jan-2013 21:54:41 UTC] Postie: Starting mail fetch
    [18-Jan-2013 21:54:41 UTC] Postie: Time: 2013-01-18 21:54:41 GMT
    [18-Jan-2013 21:54:41 UTC] Postie: Connecting to imap.gmail.com:993 (imap-ssl)
    [18-Jan-2013 21:54:43 UTC] Postie: There are 0 messages to process
    [18-Jan-2013 21:54:43 UTC] Postie: memory at start of e-mail processing:27788160
    [18-Jan-2013 21:54:43 UTC] Postie: Error log: C:\source\postie\wp35/wp-content/debug.log

    Do you have Suhoshin enabled by chance?

  7. phileasffogg
    Member
    Posted 1 year ago #

    nope, i do not know what Suhoshin is....

    i also removed an reinstalled the postie plugin with no success...

    thanks for the help

  8. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I made change in 1.4.29 that might help. Please let me know.

  9. phileasffogg
    Member
    Posted 1 year ago #

    unfortunately not. here's the debug output:

    [20-Jan-2013 09:59:19 UTC] Postie: Error log: /home/httpd/vhosts/sime.li/httpdocs/wp-content/debug.log
    [20-Jan-2013 09:59:19 UTC] Postie: Postie is in /home/httpd/vhosts/sime.li/httpdocs/wp-content/plugins/postie
    [20-Jan-2013 09:59:19 UTC] Postie: iconv: yes
    [20-Jan-2013 09:59:19 UTC] Postie: imap <small>(required for subjects)</small>: yes
    [20-Jan-2013 09:59:19 UTC] Postie: GMT: 2013-01-20 09:59:19
    [20-Jan-2013 09:59:19 UTC] Postie: Current: 2013-01-20 09:59:19
    [20-Jan-2013 09:59:19 UTC] Postie: Sucessful POP3 connection on port 110
    [20-Jan-2013 09:59:23 UTC] Postie: Checking for mail manually
    [20-Jan-2013 09:59:23 UTC] Postie: wp_content_path: /home/httpd/vhosts/sime.li/httpdocs/wp-content
    [20-Jan-2013 09:59:53 UTC] Postie: Error log: /home/httpd/vhosts/sime.li/httpdocs/wp-content/debug.log
    [20-Jan-2013 09:59:53 UTC] Postie: Postie is in /home/httpd/vhosts/sime.li/httpdocs/wp-content/plugins/postie
    [20-Jan-2013 09:59:53 UTC] Postie: iconv: yes
    [20-Jan-2013 09:59:53 UTC] Postie: imap (required for subjects): yes
    [20-Jan-2013 09:59:53 UTC] Postie: GMT: 2013-01-20 09:59:53
    [20-Jan-2013 09:59:53 UTC] Postie: Current: 2013-01-20 09:59:53
    [20-Jan-2013 09:59:53 UTC] Postie: Sucessful POP3 connection on port 110
    [20-Jan-2013 09:59:59 UTC] Postie: Checking for mail manually
    [20-Jan-2013 10:00:09 UTC] Postie: Setting tenminutes cron schedule
    [20-Jan-2013 10:00:13 UTC] Postie: Error log: /home/httpd/vhosts/sime.li/httpdocs/wp-content/debug.log
    [20-Jan-2013 10:00:13 UTC] Postie: Postie is in /home/httpd/vhosts/sime.li/httpdocs/wp-content/plugins/postie
    [20-Jan-2013 10:00:13 UTC] Postie: iconv: yes
    [20-Jan-2013 10:00:13 UTC] Postie: imap (required for subjects): yes
    [20-Jan-2013 10:00:13 UTC] Postie: GMT: 2013-01-20 10:00:13
    [20-Jan-2013 10:00:13 UTC] Postie: Current: 2013-01-20 10:00:13
    [20-Jan-2013 10:00:13 UTC] Postie: Sucessful POP3 connection on port 110
    [20-Jan-2013 10:00:16 UTC] Postie: Checking for mail manually

  10. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have mbstring installed?

  11. alasdair1234
    Member
    Posted 1 year ago #

    Hi both,

    I too (starting a few days ago) had a client reporting that Postie no longer found emails. The site in question has been running the same Postie plugin for 2 - 3 years without a hitch, so I am thinking that perhaps the issue is server side? (WHM / cPanel / Exim update?). Just updated Postie and the same issue.

    I checked out changing Postie's email box settings and also get a successful connection message (POP3) regardless of what I enter for the pass or user.

    Any suggestions?

  12. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    By chance are you using MS Exchange for the email account?

  13. alasdair1234
    Member
    Posted 1 year ago #

    Hi Wayne,

    Afraid not -just a standard POP3 WHM/Cpanel email box. I've another server with it working fine, so it looks to be specific this one, but I can't see where the config is different or what's preventing it from working correctly?

  14. phileasffogg
    Member
    Posted 1 year ago #

    no to msexchange and no to mbstring. any more ideas?

    thanks.

  15. phileasffogg
    Member
    Posted 1 year ago #

    i also tried changing the settings to a nonexisting mail server. when testing the config, i get an error as expected...

    i'm going to try another mail provider, see if that helps

    cheers

  16. phileasffogg
    Member
    Posted 1 year ago #

    i got so far as testing the config successfully (when using ssl). the test script event states the number of new emails. but when running postie manually, i still get no result: here's the debug output:

    [04-Feb-2013 17:39:09 UTC] Postie: Error log: /home/httpd/vhosts/sime.li/httpdocs/wp-content/debug.log
    [04-Feb-2013 17:39:09 UTC] Postie: Postie is in /home/httpd/vhosts/sime.li/httpdocs/wp-content/plugins/postie
    [04-Feb-2013 17:39:09 UTC] Postie: iconv: installed
    [04-Feb-2013 17:39:09 UTC] Postie: imap: installed
    [04-Feb-2013 17:39:09 UTC] Postie: mbstring: installed
    [04-Feb-2013 17:39:09 UTC] Postie: GMT: 2013-02-04 17:39:09
    [04-Feb-2013 17:39:09 UTC] Postie: Current: 2013-02-04 17:39:09
    [04-Feb-2013 17:39:09 UTC] Postie: Successful POP3-SSL connection on port 995
    [04-Feb-2013 17:39:09 UTC] Postie: # of waiting messages: 4
    [04-Feb-2013 17:39:16 UTC] Postie: Checking for mail manually

  17. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Are there no entries after "Postie: Checking for mail manually"

    There should be something like "Postie: Done"

    If not then something is crashing along the way. Do you have web server logs you can look at?

  18. phileasffogg
    Member
    Posted 1 year ago #

    okay, interesting hint. here's the log entry:
    [Tue Feb 05 21:18:07 2013] [error] [client 80.74.128.17] mod_security: Access denied with code 406. Pattern match "(TwengaBot|Voila|MJ12bot|Baiduspider|WordPress|psbot|Yeti|WebofantBot|WebAlta|Bloglines)" at HEADER("USER-AGENT") [severity "EMERGENCY"] [hostname "sime.li"] [uri "/wp-cron.php?doing_wp_cron=1360095487.1282510757446289062500"]
    [Tue Feb 05 21:18:07 2013] [error] [client 80.74.128.17] File does not exist: /home/httpd/vhosts/sime.li/error_docs/not_acceptable.html

    when executing the wp-cron.php by directly pasting it into the address bar, postie works fine....

    does not make sense to me. anyone knows mod_security?

  19. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure mod_security is the issue as it deals with incoming requests, not outbound IMAP sessions or PHP modules. Look in your error log.

  20. phileasffogg
    Member
    Posted 1 year ago #

    hmm, i don't understand. that is the error log. anywhere else i can look?

  21. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry I was thinking that was the access log.

    You could look at your php.ini file and turn on some addition error display
    http://www.php.net/manual/en/errorfunc.configuration.php

  22. BMcKenna
    Member
    Posted 10 months ago #

    I'm having the same issue and am using an Exchange address. Does that matter?

  23. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

    Yes, MS Exchange doesn't play nicely with IMAP.

    What do you get when you press the Test button?

    Can you use POP or another mail server entirely?

  24. BMcKenna
    Member
    Posted 9 months ago #

    I'm afriad IMAP is all that's available to me.

    Here's what I get when I click the test button:

    International support
    iconv: installed
    imap: installed
    mbstring: installed

    Clock TestsThis shows what time it would be if you posted right now
    GMT: 2013-06-27 15:17:46
    Current: 2013-06-27 15:17:46

    Connect to Mail Host
    Successful IMAP-SSL connection on port 993
    # of waiting messages: 0

  25. Wayne Allen
    Member
    Plugin Author

    Posted 9 months ago #

    What version of Postie are you using? I would expect to see more details and there have been some recent Exchange improvements.

  26. BMcKenna
    Member
    Posted 9 months ago #

    1.5.0. With this version as long as I access the site, the posting happens. But when I tried to update to 1.5.12, I had trouble posting at all.

  27. BMcKenna
    Member
    Posted 9 months ago #

    Sorry, I realized I should clarify something.

    The issue I'm currently running into is that the automatic checking for emails isn't happening. I have the "Check for mail every" setting in the "Mailserver" tab set to every 5 minutes. But that doesn't happen. Emails are posted only when someone accesses the site.

  28. Wayne Allen
    Member
    Plugin Author

    Posted 9 months ago #

    The WordPress cron only runs when pages are being accessed. If you want to ensure posts are being created see:
    http://postieplugin.com/forcing-an-email-check/

  29. BMcKenna
    Member
    Posted 9 months ago #

    I didn't have access to the server on which Word Press was installed. So I found out who could help me and they were able to set up a cron job. I'm all set. Thanks for the help!

  30. Wayne Allen
    Member
    Plugin Author

    Posted 9 months ago #

    Glad its working!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags