WordPress.org

Ready to get started?Download WordPress

Forums

WordPress-to-lead for Salesforce CRM
[resolved] Checkbox data is not going being sent (email or Salesforce) (5 posts)

  1. groomedmonkey
    Member
    Posted 6 months ago #

    Relevant info: http://nap.kn/d/69dwFT

    I have used the correct API ID and have a select (picklist) working correctly, but the above checkbox does not send information in the email/s sent out nor does it update the checkbox field in the Salesforce lead.

    Are checkboxes confirmed to be working in the current version?

    http://wordpress.org/plugins/salesforce-wordpress-to-lead/

  2. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    Those are radio buttons in the screenshot, not a checkbox.

  3. groomedmonkey
    Member
    Posted 6 months ago #

    I don't follow... the screenshot shows the set up in Salesforce for that field "Data type Checkbox" and underneath is the field set up in WordPress-to-Lead, which is set as "checkbox".

    The only radio button in the screenshot is the General Options for whether the Checkbox is pre-checked or not (this is in the Custom Field Definition editor in Salesforce).

  4. groomedmonkey
    Member
    Posted 6 months ago #

    Adding a Value in WordPress-to-lead solves this issue but triggers the related issue I had of the checkbox not being prechecked as it is defined in Salesforce (in screenshot linked above).

  5. Nick Ciske
    Member
    Plugin Author

    Posted 6 months ago #

    Salesforce uses non-standard names for some of its form controls. It' very confusing.

    The plugin tends to use the actual HTML control names (checkbox, radio, select).

    In this case, it may still work fine, as long as one value is blank and the other matches the value in your form. If you want 2 values, then a radio button is needed -- which is on the todo list to add (alongside checkbox lists).

Reply

You must log in to post.

About this Plugin

About this Topic

Tags