WordPress.org

Ready to get started?Download WordPress

Forums

Wiki
[resolved] check_rewrite_rules caused an infinite loop (7 posts)

  1. craynkshaft
    Member
    Posted 11 months ago #

    Hi, there seems to be an infinite looping of the check_rewrite_rules when the wiki slug setting has not been saved for 1 WordPress site in a multi-site installation. Not sure if this is on your radar or of importance to support. We commented out the function and the site (and plugin) run as expected.

    http://wordpress.org/plugins/wordpress-wiki-plugin/

  2. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    Hi @cranynkshaft

    I have a multisite setup for testing purposes. I've activated the Wiki Lite plugin on one of the sub sites, didn't touch the settings and it worked fine for me.

    Did you do anything else or have any other non-standard settings?

    If you could give us a step-by-step on how to break it that would be great!

    Thanks!
    Mike

  3. craynkshaft
    Member
    Posted 11 months ago #

    Hi Mike,

    The plugin started that infinite loop again last night (even though the slug was set). I was forced to disable to plugin and now it's back to normal. I can give you access to my site if you would like so you can take a look. I'm not a developer, but one of my guys pointed this out for me.

    Let me know.

    Best,
    Ran

  4. Mike
    WPMU DEV Support Staff
    Posted 11 months ago #

    Hi @craynkshaft

    We don't login to fix problems for the lite versions of our plugins I'm afraid.

    However if you can tell me your WordPress version, Wiki version and which page is looping I will try and re-create the issue on my test site.

    Do you just navigate to /wiki/ and get stuck in a loop or is it when trying to view an individual wiki article?

  5. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 11 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  6. craynkshaft
    Member
    Posted 11 months ago #

    Hi, thanks for following up, however, we opted to remove the plugin since it wasn't an integral part of the site. Thank you very much for following up (twice) though.

    Best,
    Ran

  7. Mike
    WPMU DEV Support Staff
    Posted 9 months ago #

    You're welcome, thanks for coming back to us and marking it resolved :-)

Reply

You must log in to post.

About this Plugin

About this Topic