WordPress.org

Ready to get started?Download WordPress

Forums

Form Manager
[resolved] Check box not displaying (19 posts)

  1. Norris416
    Member
    Posted 3 years ago #

    I'm trying to create an application form with a check box at the end. The text for the box displays, however the actual box to check doesn't.

    Please help, your form is the only one I want to use (its great).

    I'm using the Thesis theme / framework.

    Thank you!!!

    Here is a link to the test page: http://stiblermortgages.com/mortgage-application

    I am in the process of adding https to it, so if it doesn't work...add the s.

  2. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    The checkboxes are there, but really really tiny. The problem is a style conflict. If you add .fm-form input { width: 100%; } to your custom .css you should be fine.

  3. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    My mistake. You should use:

    .fm-form input[type='checkbox'] { width: 100%; }

    Otherwise it will mess with some of the other element types.

  4. Norris416
    Member
    Posted 3 years ago #

    I tried the both lines of code, but they don't work. The first one only changed the width of the submit button.

    The 2nd one didn't change anything (that I could see).

    Any ideas?

    Thanks for replying so fast earlier.

  5. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    If you go into thesis_181/custom/layout.css, on line 243:

    .format_text input, #commentform input, #commentform textarea { width: 45%; padding: 0.214em; border-width: 0.071em 0.071em 0.071em 0.071em; }

    This is the style that is causing the checkboxes to be small. At least in my browser. Which file did you edit?

  6. Norris416
    Member
    Posted 3 years ago #

    Thesis has its own control panel in the WordPress control panel called "Thesis Custom File Editor", within this control panel it allows you to edit custom.css or custom_functions.php.

    I added that line you gave me earlier to custom.css.

    What I should have mentioned earlier is that I'm great at WP, but an amateur w/ HTML / CSS etc.

    If you can figure out what needs to be changed & give me some details on how to do it, I can sort it out.

    Thanks again. Your support and service have been great. PLease help me figure this out.

  7. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    Hey its no problem. If you can insert stuff into custom.css then put this on its own line:

    .fm-form input[type='checkbox'] { width: 100% !important; }

    Or, if you can get file access to your server, the file with the 'conflict' is 'wp-content/themes/thesis_181/custom/layout.css', on line 243, but I'm not sure your changes won't be overridden later on by the Thesis control panel. At the very worst case you could add the code to the bottom of 'wp-content/plugins/wordpress-form-manager/css/style.css', but these changes will be overridden each time you update the plugin.

  8. Norris416
    Member
    Posted 3 years ago #

    Good Morning,

    No luck with adding:

    .fm-form input[type='checkbox'] { width: 100% !important; }

    To the custom.css. I tried it in box IE & Chrome.

    This afternoon I'll try and get into the style.css file, for your pluginand see if that works. I think you're right about editing the layout.css because the theme warns that editing anything outside of its custom editor, will result in it being overridden as I upgrade.

    Thanks!

  9. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    I just looked at the code for 'custom.css'. What shows up is:

    .fm-form input [type='checkbox'] { width: 100% !important; }

    Two things, the obvious one is that the single quote is being replaced by ', and the second is the space after input, both of which will break the code. You could also try it without the quotes, so it reads [type=checkbox], but you have to remove the space after input.

  10. Norris416
    Member
    Posted 3 years ago #

    Ok, so I've tried every suggested above. Didn't work...EXCEPT when I add the code to style.css it works BUT only in Safari, Chrome on Mac and Firefox on my PC.

    My PC Chrome and IE don't work. I've tried deleting cookies and all my internet files / restarting the program but it just won't work.

    I need it to work on all platforms. Any idea what the next step is?

    Thanks again for all your help.

  11. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    Maybe try this in your custom.ccs:

    .format_text input[type=checkbox] { width:100%; }

    This would be much easier if I had Thesis. Also I found this which discusses a similar issue, though somebody left a comment about your problem. You might want to look at the Thesis forums since this is more of an issue with Thesis than FM. I'm happy to keep trying, but without access to Thesis I can't know for sure what will fix your problem.

  12. Norris416
    Member
    Posted 3 years ago #

    I see the comment you mention. Exactly my problem. I did a quick scan of the thesis forums but couldn't find anything.

    If you're up for it, I can give you admin access to the theme and maybe you can look around?

    I'll keep checking thesis forums tonight and tomorrow night but since I'm code illiterate, you'll probably have more luck.

    Even though I'm having this issue, I'm still blown away by your support (and the plug in). Thanks!

  13. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    No problem. Send the info to campbell AT campbellhoffman DOT com.

  14. Norris416
    Member
    Posted 3 years ago #

    Awesome. Look for an email from Patrick.

    Thank you!

  15. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    Okay, it turns out it was a simple fix. I put this in custom.css:

    .fm-form input[type="checkbox"] { width: auto !important; }

    I tested it on FF, Safari, Chrome for Mac & PC, and IE8 for PC.

  16. nzildjian03
    Member
    Posted 3 years ago #

  17. Norris416
    Member
    Posted 3 years ago #

    You sir are amazing. Thank you so much.

    I will forever recommend you & your work. Do you have any other projects?

  18. nzildjian03
    Member
    Posted 3 years ago #

  19. hoffcamp
    Member
    Plugin Author

    Posted 3 years ago #

    No this is the only one. I appreciate the kind words, though, and good luck with your site!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic