WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Changing URL to HTTPS breaks permalinks (5 posts)

  1. timbunch
    Member
    Posted 2 years ago #

    Upon my initial upgrade to 1.9.2, only my home page would pull up. Every other page would pull up an error 404 (and not the kind that pulls up the custom error 404 page in wordpress).

    It didn't matter which settings I had checked in the plugin settings this time.

    In order to fix it, I had to change my site's general settings. I set the website url back to http:// (from https://).

    Your instructions say to make it https://. Perhaps that changed in this version, or is this a bug?

    1.9.2 fixed a wp-admin/ redirect bug when logging in, though!

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey timbunch,

    Were you attempting make your entire site HTTPS? It's possible there could be a bug in the newest version when doing that considering I didn't test it because I'm awesome. :P

    I'll look into it.

    Thanks,
    Mike

  3. timbunch
    Member
    Posted 2 years ago #

    More or less. I previously had my default website URL (within WP -> settings -> general) set to https.

    Everything seems to work fine setting it to http, though.

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    It's not generally recommended to do that unless you really have to. HTTPS will slow down your site due to all the encryption that goes on.

    I just did some testing and didn't run into any issues when changing my site url to HTTPS, so I'm not sure what the issue was with your site. It should work.

  5. timbunch
    Member
    Posted 2 years ago #

    Very good, I will make the minor adjustment and carry :)

    Thank you for such an awesome plugin and great support!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic