WordPress.org

Ready to get started?Download WordPress

Forums

Changing Theme - Now my Blog is broken (7 posts)

  1. devynci
    Member
    Posted 8 years ago #

    Hi, I really hope somebody can help me.

    I was trying to switch the theme appearance on my blog, and when I uploaded all the files, I got an error that I had a bug with index.php, and now there's nothing there at all. Are all of my posts obliterated or is there a way I can recover them? Please, if you can, I need help. Thank you in advance for reading this.

  2. Anne-Marie
    Member
    Posted 8 years ago #

    What happens if you change it back to your old theme?

  3. devynci
    Member
    Posted 8 years ago #

    I'm not sure I know how to do that since I don't have the old theme on my computer anymore. And I'm afraid of just replacing them with the originals because I might eradicate any chances of salvaging my archived entries.

  4. devynci
    Member
    Posted 8 years ago #

    Oh, I can still access everything from the admin section, there should still be hope, right? I just can't get the bloody thing to actually work (Fatal error: Call to undefined function: get_header() in /home2/azpnet/public_html/artblog/index.php on line 1) but I feel better knowing all my posts are still intact.

  5. NuclearMoose
    Member
    Posted 8 years ago #

    Your posts and comments are safe as they are in the database. In your .../wp-contents/themes/ folder lives all of the files needed for a theme. Re-upload the default theme or a new theme. You need not delete a theme in order to use a new one. I have nearly a dozen separate themes in that folder, each living inside their own folders. Then you use the PRESENTATION menu in the admin panel to choose the theme you want.
    http://codex.wordpress.org/Using_Themes would be a good read for you.

  6. devynci
    Member
    Posted 8 years ago #

    I had uploaded the theme into the main folder where my blog is, which is what messed it up, and I have no idea how to fix that.

    I should probably also mention that I think I'm using an older version of WordPress because I do not have a "Presentation" tab, I just have a template editor where I'm supposed to manually edit the pages. According to the footer in my Admin panel, I'm using WordPress 1.0.1

  7. devynci
    Member
    Posted 8 years ago #

    Ahhhh... I upgraded and got everything to work.

    Thank you everyone for your help, I really appreciate it :D

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags