WordPress.org

Ready to get started?Download WordPress

Forums

Testimonial Rotator
[resolved] Changing the Widget rotate speed (10 posts)

  1. Draelren
    Member
    Posted 1 year ago #

    I'm having an issue where when I use it as a widget, it still changes too soon to the next testimonial. How can you set the speed of it on the widget itself? I'm looking for something along the lines of 20 seconds, not 5. Thank you

    http://wordpress.org/extend/plugins/testimonial-rotator/

  2. Hal Gatewood
    Member
    Plugin Author

    Posted 1 year ago #

    try adding this to your functions.php file:

    function new_testimonial_rotator_timeout($speed) { return 20000; }
    add_filter('testimonial_rotator_widget_timeout', 'new_testimonial_rotator_timeout');
  3. Draelren
    Member
    Posted 1 year ago #

    I didn't even get a notification someone had replied... thanks for letting me know. I edited the source code and found a fix on my own, thank you though.

    I just went to testimonial-rotator.php, line 463, changed the line to:

    apply_filters( 'testimonial_rotator_widget_timeout', 30000 )
  4. Hal Gatewood
    Member
    Plugin Author

    Posted 1 year ago #

    If you ever update my plugin your changes will be wiped out. Just FYI.

  5. Bloodofeve
    Member
    Posted 1 year ago #

    Hi Hal,
    I have tried adding your `function new_testimonial_rotator_timeout($speed) { return 20000; }
    add_filter('testimonial_rotator_widget_timeout', 'new_testimonial_rotator_timeout');`
    To my website http//www.historicrydesociety.co.uk Function.php files
    I have developed my own theme using Artisteer
    When I added it to the wp function.php file it rendered this error
    Fatal error: Call to undefined function add_filter() in /homepages/39/d278883422/htdocs/.HRS_New2013/wp-includes/functions.php on line 3862
    So I tried the function.php file from my theme and got this error coade
    Parse error: syntax error, unexpected '}' in /homepages/39/d278883422/htdocs/.HRS_New2013/wp-content/themes/HRS_NewVer4/functions.php on line 752

    I'm not sure if I should be ending the fix with a } or not I have no real knowledge of PHP coding.

    If you want to have a look at the back end of my site let me know because it is behind Ultimate Maintenance Mode and I can turn it off I'm not sure why this is happening when the fix has worked for others.

  6. kanders2013
    Member
    Posted 1 year ago #

    Is there any way to change the rotator speed without editing the .php file? I've tried inserting the code you suggested into the php file, but it did not work. I am not sure what I'm doing wrong, but it would be a heckuva a lot easier if the plugin were updated so that the 'Seconds per Testimonial' actually works, and the .php file didn't need editing after each update.

  7. Hal Gatewood
    Member
    Plugin Author

    Posted 1 year ago #

    You need to be putting it in your functions.php file, if you put it there it should work and it won't need editing after each update.

  8. matthewmauck
    Member
    Posted 1 year ago #

    I also tried adding this code to functions.php and no luck. Still rotates every 5 seconds even though it's set to 20seconds in the plugin settings for the rotator I'm using.

    ---------------------------------------------
    function new_testimonial_rotator_timeout($speed) { return 20000; }
    add_filter('testimonial_rotator_widget_timeout', 'new_testimonial_rotator_timeout');
    ---------------------------------------------

    Was this ever resolved? Any way you can push an update to the plugin site?

  9. katethompson
    Member
    Posted 12 months ago #

    functions.php amend worked for me. thanks

  10. jolambourne
    Member
    Posted 8 months ago #

    Hal,

    I'm looking at the theme functions PHP section but am uncertain where to put the code you suggest? Please can you direct me where this code should be pasted?

    function new_testimonial_rotator_timeout($speed) { return 20000; }
    add_filter('testimonial_rotator_widget_timeout', 'new_testimonial_rotator_timeout');

    My testimonials are in my sidebar widget and are showing up perfectly but just rotating too quickly.

    Thanks so much a WordPress Newbie!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic