WordPress.org

Ready to get started?Download WordPress

Forums

Changing the way archive links are built (16 posts)

  1. kensav
    Member
    Posted 9 years ago #

    I'm not exactly sure what its called but I wanted to change my links from

    http://www.kensavage.com/?p=97

    to

    http://www.kensavage.com/archives/yellow-bracelets/

    Strictly for the search engines and a more descriptive/appealing looking link.

    thx

  2. eridan
    Member
    Posted 9 years ago #

    Options -> Permalinks

  3. kensav
    Member
    Posted 9 years ago #

    Yes I've done that and the links look like:

    http://www.kensavage.com/archives/yellow-orange-pink-wristbands

    but those server up 404 errors.

    The old links of http://www.kensavage.com/?p=97 still work.

    Is it because I don't have mod_rewrite installed?
    How do I check if I do have it installed OTHER THAN calling my webhost?

  4. eridan
    Member
    Posted 9 years ago #

    It's probably a mod_rewrite problem.
    Do you have shell access?

  5. kensav
    Member
    Posted 9 years ago #

    Yes I do.

    Here's my phpinfo file http://www.kensavage.com/phpinfo.php

    I don't see mod_rewrite in there. How do I install it?

  6. kensav
    Member
    Posted 9 years ago #

    anyone know how do I install mod_rewrite??

  7. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    if you're using apache, mod_rewrite should just work.

    http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Do you have a .htaccess file with the correct permissions (probably 660 or 666 depending on the setup)?

  8. kensav
    Member
    Posted 9 years ago #

    yes there's a blank .htaccess file there now with 666 permissions. When I make the change in the permalinks section and click the button the links url changes correctly but the page coming up is still 404.

  9. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Did you check out that link I gave you? I had a problem on a new server just the other day which is solved in the "Fixing Other Issues" section.

  10. skeltoac
    Member
    Posted 9 years ago #

    httpd.conf is the Apache config file. Find the line that references mod_rewrite and un-comment that line. Save, restart Apache, kablooey! I mean, voila!

  11. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Good catch, skeltoac :)

    It can depend on your server install, though. It might be apache.conf or apache2.conf. httpd.conf is probably the most likely.

  12. kensav
    Member
    Posted 9 years ago #

    ok thx.

    I'm goin in..........

  13. kensav
    Member
    Posted 9 years ago #

    ok here's what I got back from my webhost:

    Unfortunately, enabling mod_rewrite in Apache goes beyond technical support guidelines. You can contact Sales if you would like the Web Extras group to perform this at a minimal fee.

    Anyone know where I can download and install this in Apache?

  14. kensavage
    Member
    Posted 9 years ago #

    I'm looking to install mod_rewrite myself under Apache. Anyone know of a good set of instructions. My webhost wants to charge me $99 to do it.

  15. kensavage
    Member
    Posted 9 years ago #

    last bump if anyone can help?

  16. Stephanie Leary
    Member
    Posted 9 years ago #

    If they don't have mod_rewrite enabled in httpd.conf, you might still be able to do it in .htaccess. Try adding:

    RewriteEngine on

    at the top of the file. More info here and here.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.