WordPress.org

Ready to get started?Download WordPress

Forums

Changing the URL & template has messed up! (10 posts)

  1. lucyjoy
    Member
    Posted 1 year ago #

    Hey there,

    I had made my site & was all looking good, it was on the temporary address I had which was http://66.147.244.203/~thehorn3/

    I went to 'general settings' and changed site address to http://www.thehornbeams.com. When I realised this didn't work I changed it back and pressed save. Now when I visit the admin page I can't get onto any page, it takes me straight to http://www.thehornbeams.com which has nothing (just the 123 reg page) and I can see one page on the old link, but it has got rid of my template (indie fest.)

    Very confused as to what to do!

    I can't seem to get into the admin anymore as whenever I click on anything it takes me to the 123 reg page, the name i registered.

    I'm hosting on bluehost.com.

    Any help very much appreciated!!!!

    Thanks
    Lucy

  2. BH_WP_Guru
    Member
    Posted 1 year ago #

    To use your site at the .com name instead of the temporary URL, you need to make sure your .com name is pointed to your hosting company to go live with them.

    Since you don't have access to the Admin Dashboard, if you need to change it back to the Temporary URL, here's the instructions from a Bluehost video:
    https://my.bluehost.com/cgi/help/wordpressurl

  3. lucyjoy
    Member
    Posted 1 year ago #

    Hello,

    Thanks for the help. I'm back to square one - into my admin panel, but still confused as to what to do!

    So far I have set up..

    WordPress:

    1.WordPress Address (URL) http://66.147.244.203/~thehorn3
    2.Site Address (URL) http://66.147.244.203/~thehorn3

    Bluehost / phpMy Admin / wrd_options:

    1. siteurl: http://66.147.244.203/~thehorn3
    2. home: http://66.147.244.203/~thehorn3

    123.reg:

    thehornbeams.com - web forwarding not set up.

    Please can you explain which needs to point to which! thanks in advance.

    Lucy

  4. BH_WP_Guru
    Member
    Posted 1 year ago #

    After you have pointed the .com name to Bluehost, to make it go live with them, then you will change both WordPress URL's to http://www.thehornbeams.com

    You do not need to change both the dashboard URLs and the phpMyAdmin ones, they are the same. Do it on either one, and the other one is done too.

  5. lucyjoy
    Member
    Posted 1 year ago #

    Ok - what information do I type in to 123reg to point my name to bluehost?

    sorry - very new to this!

    Thanks for your help
    Lucy

  6. BH_WP_Guru
    Member
    Posted 1 year ago #

    To point the website and email to Bluehost, you'll want to change the Name Servers. Normally you get those from Bluehost, maybe in your welcome email. I think they're ns1.bluehost.com and ns2.bluehost.com

  7. swilliams4
    Member
    Posted 1 year ago #

    I'm currently working on this same task. After doing the exact same thing that you did, lucyjoy, I had to watch the video to get myself logged back into the dashboard on wordpress. Now that I'm able to do that, when I go to my page, the url address is adding a ton of extra info and then the page cannot be found.
    example:
    http://69.195.124.95/~lookinl2/blog-3/ (supposed to be the url)
    http://69.195.124.95/~lookinl2/~lookinl2/~lookinl2/~lookinl2 (its adding the extra lookinl2 onto the end of the url)

    I don't recall doing anything else to get it this messed up. I'm also not very good at all of this and could use some input as to what to do now. I'm wanting to change my url to be my domain name that is currently pointed to bluehost from go daddy. But I'm afraid to try anything different now. I was finally able to get logged back in to my dashboard and now all of this. UGH!!!!!

  8. BH_WP_Guru
    Member
    Posted 1 year ago #

    swilliams4: If it's adding the extra extesion at the end multiple times like that, it's probably your Permalinks code that's not right.

    Go into your Permalinks section of the WordPress Dashboard. Don't make any changes on this permalinks page, but simply click the Save button at the bottom. That will cause the .htaccess code to be rewritten to match your site URL and should fix that issue.

    Any time you change the Site URL and WordPress URL, go back into Permalinks and just save them again without making any changes to the Permalinks settings.

  9. swilliams4
    Member
    Posted 1 year ago #

    Oh my gosh! That workded.....BH_WP_Guru, thank you, thank you, thank you!!! Life saver indeed! :)

    I still need to get my domain name as my url instead of all the numbers, but I'm afraid to go in and try anything again after all that. ha

    To do this, do I need to go into the phpMyAdmin and change it the same way I did to get it back to my temp url as explained in the video listed above?

    Thanks again!!!

  10. BH_WP_Guru
    Member
    Posted 1 year ago #

    Yes, when you go from the Temp URL to the domain name, change both of the URLs. This can be done from the phpMyAdmin tool or you can do the same change from inside your WordPress dashboard, if you have access. They are in the General Settings area.

Topic Closed

This topic has been closed to new replies.

About this Topic