WordPress.org

Ready to get started?Download WordPress

Forums

Changing the URL - I Think I Messed Up! (10 posts)

  1. illethereal
    Member
    Posted 2 years ago #

    Uh oh! I followed the instructions on changing my URL from http://www.prairiepariah.com/blog to http://www.prairiepariah.com and I'm back to the 404 Not Found page when I try to log in wp-admin!

    He's what I did:
    I had a hard time with understanding the explanation on how to do this here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    Apparently DreamHost WebFTP cannot show hidden files, so the .htaccess isn't available for me. I followed this video: http://www.youtube.com/watch?v=0wO54hYHYF4 and did my best to work with what I had.

    I copied the index.php file to my prairiepariah.com directory and changed './wp-blog-header.php' to './blog/wp-blog-header.php' ("blog" is where wordpress is installed). Unfortunately I saved this before I changed the URL in my wordpress settings. I did it afterwards and instantly got the 404 Not Found page when I tried to log in with either http://www.prairiepariah.com/wp-admin and http://www.prairiepariah.com/blog/wp-admin

    I was nervous to do this because I fought so hard to get my site to work and now my fears have come true! I'm guessing what I did wrong is a toss up between not being able to access the .htaccess file or changing the URL of my website after I copied and saved the index.php in the main directory. That or again I just need to wait it out while wordpress or whatever is changing this for me. It looked instantaneous in the tutorial I watched though. Any suggestions on how to fix this? Maybe it's easy, but I'm an amateur and this website stuff is a HUGE learning curve for me.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Rename the index.php file in your root folder to index.php.old for now. That should allow you back into your site.

  3. illethereal
    Member
    Posted 2 years ago #

    By root folder you mean the "blog" folder that had the original index.php file and where wordpress is installed, right?

  4. Mike Schroder
    WP Contributing Dev.
    Posted 2 years ago #

    If you want to edit your .htaccess, I'd suggest using a true FTP client that supports viewing/changing hidden files (any file that starts with a '.' counts as "hidden" in *nix).

    In CyberDuck, you can do it with View->Show Hidden Files
    (you can find CyberDuck here: http://cyberduck.ch/)

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    you mean the "blog" folder that had the original index.php file and where wordpress is installed, right?

    No. Your root domain folder.

  6. illethereal
    Member
    Posted 2 years ago #

    Mike - I also have FireFTP but it wouldn't let me open and edit any of the .php files unless I open it with dreamweaver (which I'm avoiding at all costs!) so that is why I attempted to use the dreamhost WebFTP. If neither are any good then I'll use CyberDuck (really, really confused because there are so many FTP clients out there)

    Esmi - thank you for the suggestion but it seems like I still can't log in. I saved the file to index.php.old in my prairiepariah.com folder and nothing has changed :\

  7. illethereal
    Member
    Posted 2 years ago #

    It appears that with cyberduck I can only edit .php files with dreamweaver and the .htaccess won't show even when I select "show hidden files".

  8. Mike Schroder
    WP Contributing Dev.
    Posted 2 years ago #

    First, generally speaking, standard practice would be to download the appropriate files via FTP, edit them with whatever editor you prefer, then upload them again.

    That's what the FTP client will do, even if it "pretends" that it's editing the file directly on the server.

    As far as not seeing the file, even when enabling viewing of hidden files, that's a bit confusing -- I did some tests here, and the functionality certainly seems to work.

    That said, are you sure there is already a .htaccess file there to edit?

    WordPress does not create one in its home until pretty permalinks are enabled, and there definitely wouldn't be one in the root of your domain unless you created one there manually.

  9. illethereal
    Member
    Posted 2 years ago #

    Perhaps that's what it is. I was reading about pretty permalinks in the link I posted above and it just went over my head. I don't know what pretty permalinks are (again, huge learning curve). The instructions said to change to index.php and .htaccess and I became confused since I assumed the .htaccess files was something already included in the wordpress files.

    With that then maybe all I needed to do what exactly what the tutorial I posted said to do and unfortunately it didn't work out. Or, can you only change the directory if you enable pretty permalinks?

    I think it's safe to say that I have no clue what I'm doing here, haha.

  10. illethereal
    Member
    Posted 2 years ago #

    Hey guys! Still need help on this one. I'm not sure how to move forward on this :\ Also I'm starting my monthly payments my site and I'd like to well... actually have one coming along. Other than the WP forums I don't have anybody who can help me.

    Thanks for all your help! I really, really appreciate it!

Topic Closed

This topic has been closed to new replies.

About this Topic