WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
Changing skin settings appears to have no effect (11 posts)

  1. devehf
    Member
    Posted 3 years ago #

    Changing the skin to any value other than default does not appear to be working. I would like to pick a skin that is most appropriate for an audio stream. Perhaps with a button that has the label "play" instead of the triangle icon. I would also like to find a skin that will display the text encoded into the Orban Opticodec AAC audio stream which contains information about the currently playing song. This is for a community radio station:
    http://mainsite.radioboise.org/test-stream/

    Thanks,
    Dave

  2. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @devehf,

    I believe the issue with skins failing to load is because you are missing a crossdomain.xml file. The player is attempting to access the skin at http://radioboise.org/wp-content/plugins/jw-player-plugin-for-wordpress/skins/grol.zip. As a result it's making a request for a crossdomain file at http://radioboise.org/crossdomain.xml. This is then redirecting to http://mainsite.radioboise.org/crossdomain.xml which is returning a 404.

    Skins are essentially a collection of graphical elements so they are unable to display information about a stream. In this case you could probably do what you wanted by writing a plugin for the JW Player.

    Thanks.

  3. devehf
    Member
    Posted 3 years ago #

    OK I will need to do something else to display the stream data.

    I created a crossdomain.xml file. I still can't adjust the skin settings.

    Also, I can't even get the stream to work with this shortcode:
    [jwplayer file="http://amber.streamguys.com:5400/" type="sound"]

  4. devehf
    Member
    Posted 3 years ago #

    Also, once I change the admin configuration settings values of the plugin to anything from the default values, I can't change them back to default or blank.

  5. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @devehf,

    Not being able to reset the configuration settings should be fixed in the latest version of the plugin.

    As for the stream, can you provide more details about it? Is it RTMP or HTTP pseudo streaming?

    Thanks.

  6. devehf
    Member
    Posted 3 years ago #

    It's a shoutcast AAC stream.

  7. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    A few things.

    First the shortcode needs to be:

    [jwplayer file="http://amber.streamguys.com:5400/" provider="video" duration="0"]

    Second, the crossdomain being returned by http://amber.streamguys.com:5400/ is returning HTML and is not valid.

    Third, the URL to the stream itself is returning an HTML page and not actually an audio file.

    Thanks.

  8. devehf
    Member
    Posted 3 years ago #

    Video? But I'm trying to stream audio.

    Crossdomain needs to be on the streaming server? I thought it was necessary on the Flash SWF hosting server.

    The URL for that Shoutcast stream worked in audio players.

    ANyway, I think I have the solution. I asked my streaming provider to provide a different streaming server configuration. Apparently Wowza works with JW player better than Shoutcast, from what I have been told.

    This works:
    [jwplayer file="radioboise.stream" streamer="rtmp://radioboise.streamguys.com:80/live" provider="rtmp"]

  9. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Dave,

    Yeah, when using Shoutcast the audio file gets wrapped in a video container. I understand that it's counter intuitive.

    In any case, I'm glad that you got your stream working.

    Thanks.

  10. markb1439
    Member
    Posted 3 years ago #

    @LongTail Video, We're running a WordPress multisite installation, and for the most part we like the way this plugin works. For example, individual users can upload their own licensed players.

    But the skins don't work for the sub-site users, presumably because of the crossdomain issue. However, we don't want to add a crossdomain.xml file, as this can open us up to various security issues.

    Is there another way the plugin could be set up to avoid this problem? Skins are one of the main features we want to offer.

    Thanks,

    Mark

  11. JW Player
    Member
    Plugin Author

    Posted 3 years ago #

    @markb1439

    What would be a good solution for you? I'm guessing you would need skins to be stored multiple times for each site?

    It might be possible to set something to tell the plugin to look for skins in the site upload directory. Then we can either migrate skins automatically or have you just copy skins over to the relevant directory.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic