WordPress.org

Ready to get started?Download WordPress

Forums

Changing Permalinks to %postname% (4 posts)

  1. KaiserSoze13
    Member
    Posted 1 year ago #

    I have read a lot of stuff, but I feel the common opinion is that this can not be changed, without breaking the links and getting "Not found" error. However, I have read that not having this option for your pages is bad for SEO. I tried the method with adding the .htaccess file in my site's folder, but it did not help. Is there another solution, because I need my permalinks structured that way. I why is this option still available for choice, if it can not work for noobs like me?

    Any noob-friendly tips will be appreciated.

  2. Don't bump, it's really not permitted here.

    but I feel the common opinion is that this can not be changed, without breaking the links and getting "Not found" error.

    It's not a problem, the permalinks effects the post and page URLs.

    If your web server supports mod_rewrite then that %postname% will just work. If your WordPress gets the old URL then it will rewrite the old URL to the new.

    I tried the method with adding the .htaccess file in my site's folder, but it did not help.

    And it looks like your server does not support mod_rewrite. ;) Speak with your host and see if they can enable it for you. Instead of manually adding that .htaccess file you should let WordPress generate one for you (if you're doing it manually).

    If your web server can support mod_rewrite then it should just work and you should not get any 404 errors once it's enabled.

  3. KaiserSoze13
    Member
    Posted 1 year ago #

    It is 100% sure that this mod is activated. I activated the mod on my localhost test installation at home, where I have the latest version of Apace, and it is the same. :(

  4. What's the link to your site? That often shows what's going on.

    It is 100% sure that this mod is activated.

    Easy way to check: manually add these lines to the top of your generated by WordPress.htaccess file (make a backup copy first).

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule poof/ http://wordpress.org/ [R=301,L]
    </IfModule>

    Save that and visit http://your-wordpress-url-here/poof/ and if you get redirected to http://wordpress.org/ then it's working.

    If you do not get 301 redirected then mod_rewrite may be enabled but not permitted for your directory. In your Apache http conf file make sure you have this for that directory.

    <Directory />
                    AllowOverride All
    </Directory>

    That AllowOverride All is needed. If it's not there then add it and restart the apache web server (not the whole server!) for it to take effect.

Topic Closed

This topic has been closed to new replies.

About this Topic