WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changing permalinks to custom makes all categories return error 404 (9 posts)

  1. wpolitika
    Member
    Posted 3 years ago #

    Hello,

    I've been struggling with this problem for two days and I can't figure out what is wrong. The problem seems to be around for 1-2 months but only now have I noticed it.
    I am using WordPress 3.1 RC1, the website we are talking about is http://www.notebrother.com.

    The issue goes like this:
    I am using custom permalinks that have the following structure: /%year%/%monthnum%/%day%/%postname%/

    All posts work fine with this permalink structure so I suppose this is not a .htaccess problem.
    However if I try to access a category archive, let's say http://www.site.com/category/news/ I get the following error:

    Error 404 - Not Found

    We're very sorry, but that page doesn't exist or has been moved.
    Please make sure you have the right URL.

    This problem disappears if I revert to the default permalinks. Using http://www.site.com/?category_name=news works all the time, regardless of what I am doing to the permalinks.

    Also if I want to use %category% in the permalink structure, this will make all posts inaccessible, but without an error, the server will simply not be able to process the request and act as if it's down.

    I tend to believe this might be due to a bug in version 3.1. Please, any help would be greatly appreciated.

  2. What's in your .htaccess file and are you sure it's being read?

  3. wpolitika
    Member
    Posted 3 years ago #

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Permissions are set to 666. The server is using Apache.

    Told you, this issue appears only when trying to view category archives.

  4. Yeah, but that doesn't mean it's not an .htaccess problem :) You don't have anything else in your .htaccess file? No personalized tweaks?

    Have you tried re-saving your permalinks? That is just going into the permalink page on wp-admin and clicking 'save'?

    Have you tried any other permalink variations besides YYYY/MM/DD/POSTNAME and 'ugly'?

    The fact that http://www.notebro.eu/?category_name=noutati/ works where as http://www.notebro.eu/category/noutati/ does NOT implies that your .htaccess IS NOT being parsed correctly by your host. It's supposed to pretty-format that.

    Do you have any caching plugins?

  5. wpolitika
    Member
    Posted 3 years ago #

    Yeah, but that doesn't mean it's not an .htaccess problem :) You don't have anything else in your .htaccess file? No personalized tweaks?

    NO

    Have you tried re-saving your permalinks? That is just going into the permalink page on wp-admin and clicking 'save'?

    YES - doesn't work

    Have you tried any other permalink variations besides YYYY/MM/DD/POSTNAME and 'ugly'?

    YES - the problem exists only as long as I am using a custom permalink structure, so other variations have the issue (except default).

    I've also tried with all the plugins and themes disabled, the issue is still there.

    I don't know what else to think of...

  6. I hate to say it, but I think your server isn't reading the .htaccess correctly, then. Yes, it works from SOME links, but the fact that it's NOT redirecting http://www.notebro.eu/?category_name=noutati at all implies that something's not being read.

    Try this... Put this at the top of your .htaccess
    AllowOverride FileInfo Options

    You may need to ask your host to turn that on in the httpd.conf settings for your domain, though.

  7. wpolitika
    Member
    Posted 3 years ago #

    The result is

    Internal Server Error

    And the whole site goes down.

    So what exactly do you suggest I ask my host provider?

  8. Tell your host that you don't think your full .htaccess is being correctly honored, as it's not allowing URLs to be replaced. Could they add AllowOverride FileInfo Options to the httpd.conf settings for your domain?

  9. wpolitika
    Member
    Posted 3 years ago #

    I've talked with the host provider and everthing was fine with them.

    Thus my only solution was to reinstall WordPress.

    After reinstall everything seems to be working fine now.

    Thank you for your support.

Topic Closed

This topic has been closed to new replies.

About this Topic