WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changing Permalinks Cause 500 Error (12 posts)

  1. llprimajr
    Member
    Posted 2 years ago #

    (3.4.1 not offered as option)
    I downloaded a second WordPress to my FTP database to rebuild my site.
    http://www.louisprimajr.com/permalinktest
    I uploaded Music Pro theme, but did not activate it. I am Theme is currently set to Twenty Eleven.
    In WordPress/Settings/Permalinks I changed the permalinks from default to Post name and saved changes. At the top of the page, received this.

    "Permalink structure updated. Remove write access on web.config file now!"

    Clicking onto any other page at all, attempting to access site, or wp-admin results in this error.

    "500 (Internal Server) Error"

    Any help is greatly appreciated.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    1. Where did you install WordPress? At the root or at http://www.louisprimajr.com/permalinktest ?
    If it is at this address, I don't think WP is installed. That is why you get an error message.

    2. If you have setup WP at /permalinktest, search engines and testing tools are blocked by the server. Because which you get a 404 error as well as HTTP/1.1 500 URL Rewrite Module Error.

  3. llprimajr
    Member
    Posted 2 years ago #

    @Krishna,
    I build my initial WordPress site at /wordpress, not the root. As well as a second build at /NewWordPress.
    There has never been an issue prior to upgrading to 3.4.1.
    I currently have another WordPress install at /siteedit that is working fine. A previous install (that I deleted) began having the problems, which is why I installed at /permalinktest to use for support.
    Everything works fine until I change the permalinks to Post, then the entire site shuts down.
    On my active site http://www.louisprimajr.com (which was built prior to 3.4, the permalinks are set to post, and updating to 3.4 and 3.4.1 did not effect the site.
    I believe I need to "Remove write access on web.config file now!" as suggested, but do not know how, as I cannot even get into admin.
    The site I have built at /siteedit is ready to go once I know how to change the permalinks without error.

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    You need only one (/siteedit), or the others you referred to also? However, if it is OK, you can setup others too in the same manner as you set it up.

    What permalink structure you like?

  5. llprimajr
    Member
    Posted 2 years ago #

    Yes I know, the reason I installed the others, is that when I changed the permalinks in /siteedit, it shut down the site and I had to delete the database. I created the /permalinks error as an example for this request for help, and so I can work on the new site in /siteedit.
    Anyway, I merely need to know how to
    "REMOVE WRITE ACCESS ON WEB.CONFIG"
    or prevent the error from happening when I change the permalinks prior to publishing to the root.

  6. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Where do you find WEB.CONFIG ?

  7. llprimajr
    Member
    Posted 2 years ago #

    In WordPress/Settings/Permalinks
    After changing permalinks from Default to Post and hitting Save Changes.
    In a yellow bar across the top of the page received this message.

    "Permalink structure updated. Remove write access on web.config file now!"

  8. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    So, you are using Windows hosting, isn't it? You can look for it at your root directory (not likely, as most hosting services keep it hidden). If so, you make a request to your host to make the changes.

  9. llprimajr
    Member
    Posted 2 years ago #

    Thank You Krishna,
    I was able to remove the write access on web.config.
    However this did not work.
    GoDaddy support told me it was a problem with the web.config in my root, and removing this shut my entire site down, so doin this for the root is not an option.
    They suggested I seek help regarding Multiple WordPress databases on a site.

  10. llprimajr
    Member
    Posted 2 years ago #

    At GoDaddy suggestion, I searched support topics regarding Multiple WordPress Installs on One Hosting Account.
    I found a 2 year old topic, to which a reply to the thread directed me here
    http://www.globalartwork.com/2009/wordpress-permalinks-on-windows-iis/
    And wow was this a simple fix.
    In case anyone is having the same issue with GoDaddy.
    Simply open your FTP file manager.
    Click on the wordpress install you are having problems with.
    put a checkmark in the box next to the web.config file.
    Click EDIT
    and copy and paste from this file http://www.globalartwork.com/web.config.txt
    click save and everything now works.
    Thank you to Globalartwork for having the answer

  11. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @llprimajr,
    Glad to see that you could solve your problem. Also thank you for sharing the info about how you could do it, as it can help others having similar problems.

  12. peggyst
    Member
    Posted 1 year ago #

    Thank you for posting that fix!

    I also have wordpress in a subdir under my root, and will leave it there until I'm ready to replace my original website with the wordpress site. I do not have multiple wordpress subdirs, but I did have multiple webconfig files.

    This fix worked for me, when I had the internal server error as well.

Topic Closed

This topic has been closed to new replies.

About this Topic