WordPress.org

Ready to get started?Download WordPress

Forums

Changing permalink structure plain and simply doesn't work (3 posts)

  1. Scottscd
    Member
    Posted 5 years ago #

    Hi folks.

    I'm running the latest version of wordpress. My current permalink structure is default but I want to change it to ID and postname structure. I can go into the dashboard and do this, then when I check my blog the urls have all changed. However they come up as 404's when you go to click the individual blog posts. The old default links still work but the new ones are dead.

    Now I think this is a windows server. There's no .htaccess and I remember my host mentioning this. Not sure if that effects anything.

    My blog is here via this redirect link. I'm just using this so the search engines don't pick this up. If this forum is set up so they wont spider it then please feel free to post up the proper URL.

    Any help with this would be much appreciated. I'm struggling on what to do.

  2. moshu
    Member
    Posted 5 years ago #

    Now I think this is a windows server.

    Yes, that always is a problem. Why are you on a Win server?

    More: Using_Permalinks#Permalinks_without_mod_rewrite

  3. Scottscd
    Member
    Posted 5 years ago #

    Not sure really. I have a good quality webhost but they seem to use windows servers.

    Do you think this is what will be causing the issue? Should I think about switching hosts or switching to a Linux hosting plan?

Topic Closed

This topic has been closed to new replies.

About this Topic