WordPress.org

Ready to get started?Download WordPress

Forums

Changing "Pages" to "Contact Me" with no sublink (9 posts)

  1. davincim
    Member
    Posted 9 years ago #

    Instead of having Pages > Contact Me in my sidebar, I just want it to say "Contact Me" and have that be the link to my page where the contact form resides.

    In my sidebar.php it says:

    <?php wp_list_pages('title_li=<h2>' . __('Pages') . '</h2>' ); ?>

    So I figure that's what needs changing, but how do I do that?

  2. oriecat
    Member
    Posted 9 years ago #

    Maybe try <?php wp_list_pages('title_li= '); ?>

  3. davincim
    Member
    Posted 9 years ago #

    Oh I see, I think. ' . __('Pages') is the name of the page and by removing that the title "Pages" should now be the link, right?

  4. davincim
    Member
    Posted 9 years ago #

    Tried it, and it worked BUT after I tagged it with <h2> it's indenting over to the right a little. I thought the h2 tag would have fixed that. Any ideas?

  5. davincim
    Member
    Posted 9 years ago #

    Made a few more tweaks. Tried adding the li tag to that line because I saw the other similar headings marked that way, but still no cigar.

    Here's my blog in case anyone has a sec to look at the problem: link

  6. Lorelle
    Member
    Posted 9 years ago #

    Dump the H2. Leave it as li and get rid of the H2 parameter. That's a title headline and not what you want for size, I'm sure.

    <ul><?php wp_list_pages('title_li='; ?></ul>

    or

    <ul><?php wp_list_pages('title_li= '; ?></ul>

    The second one has a space after the li= and it changes the output, but with the Codex down, I can't remember what it specifically does. Hey, at least I remember this much! Try both and see how they do and make sure you put the UL around them.

  7. davincim
    Member
    Posted 9 years ago #

    Actually, I was trying to get it that size. Making it li just makes it small and out of aligment.

    If you check my page out once more, you'll note I added a "Home" link. I just tagged it with H2 and it worked. What is it about the php that's making "Contact Me" ignore the H2?

  8. davincim
    Member
    Posted 9 years ago #

    Sorry Lorelle, looks like we were typing over each other. :)

    I tried both your changes, but I'm getting a parsing error. ??

  9. davincim
    Member
    Posted 9 years ago #

    Hold on, I'm thinking that parsing error may be related to HashCash that I'm currently working on. But I've got another topic posted where I'm asking questions about that. I'm waiting on the fix.

    There are a few files that I've updated for HashCash, but haven't uploaded them all. Once I get the fix for it, then I'll repost here to continue this thread.

    Thanks for your help. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.