WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Changing locale from en_US to en_AU (4 posts)

  1. an52
    Member
    Posted 1 year ago #

    The site is http://www.trainsem.com/

    I have edited wp-config.php and uploaded the en_AU.mo file after renaming it from en_GB.mo.

    The top part of the page code looks like it has picked up the locale as Australia:

    <!DOCTYPE html>
    <!--[if IE 7]>
    <html class="ie ie7" lang="en-AU" prefix="og: http://ogp.me/ns#">
    <![endif]-->
    <!--[if IE 8]>
    <html class="ie ie8" lang="en-AU" prefix="og: http://ogp.me/ns#">
    <![endif]-->
    <!--[if !(IE 7) | !(IE 8) ]><!-->
    <html lang="en-AU" prefix="og: http://ogp.me/ns#">

    However, the Yoast SEO plugin v1.4.13 part of the code hasn't changed:

    <meta property='og:locale' content='en_US'/>

    What is causing this and how to fix it?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 1 year ago #

    I just checked in the code - the reason for this is that Facebook only supports a limited list of locales and en_AU is not supported. Which is why it the og:locale defaults back to en_US.

    If Facebook has started to support en_AU, it could be added to the valid locales list.

    Hope this helps.

    Smile,
    Juliette

  3. an52
    Member
    Posted 1 year ago #

    Oh, that's sad. Thanks for checking. I hope in the future it won't affect currency matters, so I can live with en_US.

  4. lnietob
    Member
    Posted 10 months ago #

    I have the same problem my site is http://www.teksyte.com I am using yoast Version 1.4.15 but I can't find where to tweak this en_US for en_GB

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags