WordPress.org

Ready to get started?Download WordPress

Forums

Changing Lanuage or WPMU 2.9.2 fails (7 posts)

  1. idotter
    Member
    Posted 4 years ago #

    Hi there

    I have WPMU installed (with Buddypress) here: connect.idotter.ch

    I'd like to change Language to German for my Endusers (Front- & Backend). I created the directory wp-content/languages and pasted the file de_DE.mo. Then i changed the language Settings in Site Admin-> Options and Settings -> General to German with no effect. Is this a bug or did i miss anything ?

  2. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    Did you add your language in wp-config.php?
    http://codex.wordpress.org/Editing_wp-config.php#Language_and_Language_Directory
    Additional reading
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language
    http://codex.wordpress.org/WordPress_in_Your_Language

    I saw some threads in WPMU forums regarding this matter, so please do a search there - http://mu.wordpress.org/forums/

    I have used this plugin http://wordpress.org/extend/plugins/sitepress-multilingual-cms/ for WPMU with users blogs posted in different languages. That would be overkill for the one language sitewide in your case, but might provide you some hints as well.

    Good luck.

  3. idotter
    Member
    Posted 4 years ago #

    yes i did everything as written on codex.wp.org

    didn't found anything ... do you have a hint for me ?

    please can anyone help me ... it seems that this is a bug ! i also got "Corsican" as a language besides english and german but didn't install this!

  4. Go over the steps here:
    http://wpmututorials.com/how-to/localization/

    And also make sure you have the *BuddyPress* translation files as well.

  5. idotter
    Member
    Posted 4 years ago #

    I did as you mentined on wpmututorials.com ... no chance to see anything in german

    :-(

  6. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    Don't know why Corsican is appearing there, check if you have installed a plugin/theme which added that to your install.

    1. Add the de_DE.mo also to wp-includes/languages/

    2. Plus - http://patrick.bloggles.info/2009/05/17/wpmu-admin-language-plugin/

    3. Also make sure that the theme you are using is translatable - for some examples of translatable themes, see source code of BP bp-default theme files or WP's Classic Theme files

  7. idotter
    Member
    Posted 4 years ago #

    1. I tried also with wp-includes/languages a while ago
    2. I don't want to use a plugin for translations if theres support for this in the core
    3. BuddyPress and a part of the THeme is translated, my problem is the WP-backend where neither the files nor the settings i changed to german affects the language

Topic Closed

This topic has been closed to new replies.

About this Topic