WordPress.org

Ready to get started?Download WordPress

Forums

changing image url (5 posts)

  1. kas187
    Member
    Posted 5 years ago #

    Hello,

    I'm trying to change the image url to which the images get uploaded to in wordpress from the default http://domain/wp-content/uploads/2008/08/imagename.jpg to something simple like:
    http://domain/images/imageurl.jpg

    Can anybody direct me on how to achieve this?

  2. stvwlf
    Member
    Posted 5 years ago #

    In the dashboard, Settings / Miscellaneous

  3. kas187
    Member
    Posted 5 years ago #

    ok but will this also create the 'images' folder for me and if not then do i need to create one within the main folder structure i.e. where the wp-admin and wp-content folder sit?

  4. kas187
    Member
    Posted 5 years ago #

    still not working, im working locally so here's what i've done:

    1. Went to Settings > Miscellaneous Removed original path
    2. Added a full local path: http://localhost:1234/domain/images
    3. Unchecked 'Organize my uploads into month- and year-based folders' option

    Tested by uploading a new image which is being added to wp-contents > uploads folder but in the editor it is writing out the the following path: http://localhost:1234/domain/images/imagename.jpg

    So the image isn't being added to the images folder, any suggestions?

  5. mike_groupie
    Member
    Posted 5 years ago #

    To answer your original question:
    1. Settings -> Miscellaneous
    2. Store uploads in this folder = "images"
    3. Clear the "Full URL path to files" field
    4. Uncheck the "Organize my uploads into month- and year- based folders"
    5. Save Changes

    When you upload a new image, it will create the "images" file if it doesn't already exist and upload an image to http://domain/images/imagename.jpg instead of http://domain/wp-content/uploads/{year}/{month}/imagename.jpg

    If WP is NOT installed in the root directory (ie: http://domain/wp), but you want to upload images to a directory in the root directory (ie: http://domain/images), then you need to specify a PARENT directory:
    1. Settings -> Miscellaneous
    2. Store uploads in this folder - "../images"
    3. Clear the "Full URL path to files" field
    4. Uncheck the "Organize my uploads into month- and year- based folders"
    5. Save Changes

    Again, WP will create the "images" directory for you, and images will be uploaded to http://domain/images/imagename.jpg instead of http://domain/wp/wp-content/uploads/imagename.jpg

Topic Closed

This topic has been closed to new replies.

About this Topic