WordPress.org

Ready to get started?Download WordPress

Forums

Changing home page back to a blog (10 posts)

  1. Rachel Costello
    Member
    Posted 1 year ago #

    I originally had a static page for my "Home" page. I would actually like to have this changed back to a blog-style page to show my posts. I cannot figure out how to do this.
    I tried changing it in Settings - Reading, by clicking Front Page displays your latest posts. All that shows up under my navigation bar is wp_head();
    My sidebar isn't there either.
    New to wordpress and very confused...please help.
    website is http://www.kalerecords.com

  2. jamesg40
    Member
    Posted 1 year ago #

    When you set a homepage before did you set a template file in the page attributes for the homepage? I think its right side of the wysiwyg editor. If you set a page template file for any of the pages, blog or homepage, it will mess you up every time, lol.

  3. Rachel Costello
    Member
    Posted 1 year ago #

    Oh gosh, I actually don't know. I notice on the page editor, there is a box to the right called "page attributes" with a drop-down template menu. Should I set all of the pages to "default template"?

  4. Rachel Costello
    Member
    Posted 1 year ago #

    So I deleted the page I had originally had as my static landing page and I checked to make sure all my other pages are set to "default template" (they already were). But now, when you go to the site it still has that wp_head(); and is showing no posts. Please help!
    http://www.kalerecords.com

  5. jamesg40
    Member
    Posted 1 year ago #

    I see the problem but would need to see the index.php or home.php (if you have one) to be sure. It basically looks like you have some commented out stuff just under this container (section-header) that looks like this

    <!-- End SuperContainer -->
    <!-- ============================================== -->
    wp_head(); <!------this shouldnt be here
    <!-- ============================================== -->
    <!-- FlexSlider -->
    <!-- ============================================== -->
    <!-- Super Container - Three Column Row - Content comes from OptionTree -->

    take that wp_head(); out. It belongs in the head with the meta info and your stylesheet links and all. You can add it just above the </head> tag like this <?php wp_head(); ?>

  6. Rachel Costello
    Member
    Posted 1 year ago #

  7. Rachel Costello
    Member
    Posted 1 year ago #

    and here is the home.php
    https://gist.github.com/4469785

  8. jamesg40
    Member
    Posted 1 year ago #

    on header.php remove the wp_head(); at line 2 and save. thats whats messing you up for the main issue. When you remove that, You may have to select a page template or something similar but you may also have some other issue. I dont really know that theme so I cant be 100% sure, seems like there should be some options. Plus, your using super skeleton. Not sure what options he has builti into it but it looks like just a rapid development template, so you may be required to do some extra stuff to get it all the way you want, but your site design looks good and the pages flow nicely, let me know how that fix works for you and if you have any other issues.

  9. Rachel Costello
    Member
    Posted 1 year ago #

    Thanks James,
    Now the “wp_head();” is not there but it is still not showing my blog posts.
    Do I have to do something to re-create a Home page that shows my blog?
    Thanks for your help!

  10. jamesg40
    Member
    Posted 1 year ago #

    Like I said, I don't really know the theme to well but you may want to try this first. Make a homepage and see if there are page templates in the page attributes drop down in the page editor, if there are options for templates, simply choose one and see what happens, Also, be sure the settings under reading are correct, if you have have it set to Front page displays Your latest posts (Or) if you have it set to A static page and make adjustment there to be sure your not throwing yourself off, lol. You may want o set it to the default setting (Your latest posts ) and see what that does. Also, if you not seeing changes when you refresh your page, try to clear your browser cache and history, sometimes things get stuck displaying the same even though we made changes when we dont clear our browser cache. I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic