WordPress.org

Ready to get started?Download WordPress

Forums

Changing folder hierarchy (1 post)

  1. Photog
    Member
    Posted 1 year ago #

    For the past couple of years, I've had my site set up such that the WP folders were in a subfolder on my server called /blog.

    In the General settings I had the WordPress address as rf-photography.ca/blog and the Site address as rf-photography.ca I had the index.php file set up to properly reference the /blog subfolder and the htaccess file was set up properly for the permalink structure I used.

    Sometime over the weekend something went haywire with the site and it was inaccessible. I couldn't access the main site address nor could I log into the Dashboard.

    I contacted my web host and finally, today, 2 1/2 days later got them to look into the problem. They managed to screw it up even more than it was before.

    I am; however, at least able to log into my dashboard again. I've got the site back about 90% to where it should be. The one thing that I still can't resolve is that the homepage of the site is pointing to rf-photography.ca/blog rather than rf-photography.ca. In the General> settings I've made sure that the WordPress and Site URLs are set up properly. Earlier this summer, I set up a static landing page and in the Reading settings I had set up the Welcome page as the static landing and Blog as the main posts page. That all worked fine till a few days ago. I've verified that the Reading settings are set up properly.

    I've verified that everything is set up properly according to this article but I still can't get the Welcome page to show and be the main landing page for the site. If I'm in the site and click on Welcome or the banner at the top of the site (which should go to the Welcome page) it goes back to rf-photography.ca/blog.

    Two questions:
    1. What might I be missing that I can't get the Welcome page to be active
    2. If I got rid of the /blog subdirectory on my server, put all of the WP files in the root directory and edited the index.php file such that it no longer pointed to the /blog subdirectory would that be likely to solve the problem.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.