WordPress.org

Ready to get started?Download WordPress

Forums

Changes to Template Files not responsive on Dreamhost (3 posts)

  1. hapworth
    Member
    Posted 7 years ago #

    Alright guys, this is driving me absolutely up the wall. I currently have an account with Dreamhost and used their One-Click Install to setup WP. This is not new for me. Running the latest version and have done this several times.

    The site behaves fine, albeit a little slow at times. But the crux of my problem is while I'm making changes to my templates via either the theme editor or even from the shell, changes don't seem to show up for quite awhile.

    And yes, I have cleared my cache several times, (I even have caching turned OFF in Firefox), tried it from different browsers (FF2 and IE7), even used other programs to clear all of that stuff (CCleaner) and even tried it from a different computer (an OSX box, not that it matters. My primary machine is a PC running XP).

    Just to clarify, I have even tried modifying existing working designs, and I know the issues of sometimes CSS code not behaving the way it should. I try changes out in FF2's Web Dev Bar so I see the changes on the fly. But when I edit the files in question, nothing. Not to mention I'm a bit of a Standards Junkie so I'm not trying anything kooky here.

    Also, I have a Drupal site running on Dreamhost as well and any updates or changes I make to the site occur immediately, whether it's within their framework or via the shell. This is all under the same account (of course, diff domain and dir).

    You can imagine how irritating this is when I'm trying to tweak and customize my themes. Is anyone else experiencing this at all? This only seems to happen on DH One-Click Installed WP Installations for me. Even Gallery which I'm running behind it updates fine when I modify THEIR templates.

    Oh, and I've turned off wp-cache for the time being as well thinking something is persisting on the server side. Nothing.

    For pre-made templates, I've tried making changes with the files in place, and have checked several times that I'm editing the correct ones.

    I've already put in a support request and 18 hours have past with NO response. Their current status page reflects no outages right now. Does anyone have any clue as to what might be going on here? I would really appreciate anyone who can bring back my sanity. Much appreciated.

  2. Chris_K
    Member
    Posted 7 years ago #

    I'm on dreamhost and not having similar issues.

    Disabling the wp-cache plugin isn't really sufficient, for whatever reason. Better to enable it and then visit Options-> WP-Cache and use the disable button at the top of *that* page.

    Or just scroll down and click "clear cache" after making changes.

  3. jojo0507
    Member
    Posted 7 years ago #

    Really? It's not responsive to your updates?

    I have Dreamhost too, and just to make things worse, I am in London while they are in California.

    All the changes to my THEME shows up immediately.

    Changes to the MySQL Database (ie new posts) ought to show as fast..?

    Technically, that behaviour doesn't make any logical sense. If the post is in the db, it's in the db and should be retrieved immediately and show up in the blog. There is no in between place where the post can be.... Unless there is some kind of weird backup / data duplication scheme that means you are saving to one db and retrieving from another, in which case the duplication could take a while.

    Strange..!!

    Having worked in tech support in the past I can tell you that tech support always responds better if you have a reproducable example of the problem - so they can trigger it and see it with their own eyes.

    Their turnaround has been around 6 hours for me when I reported problems. Acceptable so far.

    Hope you'll find a solution!

Topic Closed

This topic has been closed to new replies.

About this Topic