WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changes made in Theme Editor not showing up in browser (5 posts)

  1. jencardello
    Member
    Posted 7 years ago #

    Starting last night, I made edits to several php files (index.php, sidebar.php) for http://www.sitediagnosis.com, but the pages showing up when I click on "View site" from the Theme Editor (sitediagnosis.com/blog) and when I just type in the site's URL (www.sitediagnosis.com) do not reflect changes. As well, they look different/are using different code even though they have always been the same in the past.

    Upon further investigation with Yahoo tech support, it was discovered that I have 6 different index pages scattered throughout my files.
    Root level: index.html and index.php
    /blog level: homepage-index.php and index.php
    /wp-content level: index.php
    /themes/my theme level: index.php

    Is this normal? Should I get rid of some of these index files? Is the theme editor updating the wrong index file? I've made a lot of edits before and never had this problem. Could it have something to do with Yahoo?

    Thanks in advance.
    --jc

  2. Chris_K
    Member
    Posted 7 years ago #

    It could have a lot to do with Yahoo.

    The only index.php that you care about is the one in your theme's directory. And trust me, that's the one that built-in theme editor is using. Don't worry about the others.

    By default, Yahoo's WP install has wp-cache installed. So, after you make changes and want to actually see them, don't forget to visit options -> wp-cache, scroll down a bit and click the "Delete Cache" button.

    And, of course, don't forget to clear your browser's cache too. Ctrl-F5 works with many browser to force a full page reload.

  3. spencerp
    Member
    Posted 7 years ago #

    EDITED* Damn! Handy beat me by a second!! =P

    It sounds like you might have the wp-cache plugin enabled, try disabling that once.. Do hard clear of cache CTRL + F5.. you might have to comment out the line for the wp-cache in the wp-config.php file too.. But, for now.. just disable the wp-cache plugin once, if you have it enabled..?

    Related solution here. Good luck!

    spencerp

  4. jencardello
    Member
    Posted 7 years ago #

    Excellent! I disabled the wp-cache and deleted the cache and all seems well. Thank you! Thank you! Thank you! :)
    --Jen C.

  5. spencerp
    Member
    Posted 7 years ago #

    You're welcome from the both of us.. ;) =) As long as I can get the FIRST virtual kiss though, even though he beat me by a second.. lol! He married, I'm not.. hahaha.. =P Just kidding..

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags