WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Changes in "style.css" do not affect the web page (25 posts)

  1. mbes
    Member
    Posted 7 months ago #

    My site is http://www.smadarandhadas.com and the style.css code in the customizr child is as follows below. The web page does not obey instructions!

    `/*
    Theme Name: Customizr Child
    Theme URI: http://www.smadarandhadas.com/
    Description: Child theme for the Customizr theme
    Author: Brian Rogers
    Template: customizr
    Version: 0.1.0
    */
    @import url('../customizr/style.css');

    /* =Theme customization starts here
    -------------------------------------------------------------- */
    body
    {
    font-family: cursive, "Comic Sans MS", sans-serif;
    font-style: normal;
    font-size: 24px;
    } `

  2. clouder
    Member
    Posted 7 months ago #

    I'm having the same type of experience. Whatever I change in the child theme doesn't show any changes. Can I ask who your host is?

  3. mbes
    Member
    Posted 7 months ago #

    GoDaddy

  4. clouder
    Member
    Posted 7 months ago #

    Oh okay. So its not an issues with the host cuz I'm using a different host.

  5. zoeromero
    Member
    Posted 7 months ago #

    I have the same problem ! Can anyone help ?

    thanks

  6. rdellconsulting
    Member
    Posted 7 months ago #

    Try " instead of ' ie
    @import url("../customizr/style.css") ;

    Not sure if this will make any difference...

  7. zoeromero
    Member
    Posted 7 months ago #

    In my case I have " instead of ' and is not working...

  8. rdellconsulting
    Member
    Posted 7 months ago #

    @mbes, your link caused my browser (Firefox) to loop and never found your site.

    @zoeromero, do you have a site link?

  9. zoeromero
    Member
    Posted 7 months ago #

    here it is: http://www.mouvart.fr

  10. rdellconsulting
    Member
    Posted 7 months ago #

    @zoeromero, did you upgrade to 3.0.10? May be nothing to do with this problem, but I see you have an old bug with your social icon showing as F204. I thought this was fixed in 3.0.10.

    This link shows how plugins were a problem, so see if this helps:
    http://wordpress.org/support/topic/genericons-font-for-sm-icons-not-working-in-firefox

  11. zoeromero
    Member
    Posted 7 months ago #

    I've just upgraded to 3.0.10, but both problems (style.css and icons) persist...

  12. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 7 months ago #

    Can you link us to your Child Theme style.css file?
    E.g, http://mouvart.fr/wp-content/themes/customizrchildtheme/style.css

  13. zoeromero
    Member
    Posted 7 months ago #

    Here it is. You can see below all the customizations that do not work

    /*
    Theme Name: Customizr child theme
    Description: Child theme for Customizr
    Author: Zoe
    Template: customizr
    */

    @import url("../customizr/style.css");

    .navbar .nav > li > a, .navbar .nav > li > a:firstletter {
    color: white;
    }

    .navbar .navbar-inner {
    -webkit-box-shadow: 0px 0px 0px;
    -moz-box-shadow: 0px 0px 0px;
    box-shadow: 0px 0px 0px;
    }

    .navbar .navbar-inner {
    -webkit-box-shadow: 0px 0px 0px;
    -moz-box-shadow: 0px 0px 0px;
    box-shadow: 0px 0px 0px;
    background:none
    }

    .format-icon:before {
    speak: none;
    text-transform: none;
    -webkit-font-smoothing: antialiased;
    padding-right: 10px;
    opacity: 0.2;
    position: relative;
    top: 8px;
    display: none;
    font: normal normal 1.2em/1 'entypo';
    }

  14. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 7 months ago #

    Can you send us a link to your Child Theme style.css file?

  15. Fairytail17
    Member
    Posted 7 months ago #

    Hi everyone,

    @zoeromero: I went on your site and your style.css file that is loaded does not look at all like the one you shared. It's actually a whole HTML file : http://www.mouvart.fr/wp-content/themes/customizrchildtheme/style.css?ver=3.0.9

    Are you sure you modified the right file ?

  16. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 7 months ago #

    @zeoeromero if you can confirm that is the CSS file you've modified then you need to contact your hosting providers as to why it cannot be accessed.

  17. mbes
    Member
    Posted 7 months ago #

    Hi everyone,

    I think I have stumbled onto a solution - a work around actually. While working on the CSS changes and checking results on my computer, nothing seemed to alter the site.

    By chance, I was working on another computer and decided to look at the site I was trying to build. Lo and behold the changes in the CSS file came through. On returning to my original computer and checking out the site, I found that the web page was unchanged.

    I suppose it has something to do with the difference between a normal user and the site administrator.

  18. zoeromero
    Member
    Posted 7 months ago #

    @Fairytail 17 yes, it is the same. I modified it from the wordpress editor and then verified it was the same in the FTP file. What do you mean with a whole HTML file? I created it with the child theme

    @Andrew Nevins yes I can confirm so I will contact them...

    @mbes I oponed to site in another computer, same problem

  19. Fairytail17
    Member
    Posted 7 months ago #

    Hi, when i go on the homepage of mouvart.fr, i can see that the code loading the style.css file in your header is the following:
    <link rel="stylesheet" id="customizr-style-css" href="http://www.mouvart.fr/wp-content/themes/customizrchildtheme/style.css?ver=3.0.9" type="text/css" media="all">

    However, when i open this file i see a 404 page.

    I think that when you created your child theme, you forgot to create style.css in your child theme directory and therefore it searches for it but can't find it. You should have style.css file with the modifications you stated earlier in your childtheme directory --> http://www.mouvart.fr/wp-content/themes/customizrchildtheme/

    Does that make sense ?

    Check the difference in the pages here
    Grey.css from the template: http://www.mouvart.fr/wp-content/themes/customizr/inc/css/grey.css?ver=3.0.9
    style.css from your child: http://mouvart.fr/wp-content/themes/customizrchildtheme/style.css?ver=3.0.9

  20. ElectricFeet
    Member
    Posted 7 months ago #

    @mbes

    I suppose it has something to do with the difference between a normal user and the site administrator.

    More likely it's a caching problem on your first PC.

  21. zoeromero
    Member
    Posted 6 months ago #

    @Fairytail17 one of the first things that I have done when I installed the theme is to create a style.css in my child theme with all the modifications... so I don't know how it does not work.

    thanks all for your comments.

  22. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 6 months ago #

    @Fairytail17, why take support away from these forums if, as you say, you cannot provide it?

    @Zoeromero, any news from your hosting providers?

  23. Fairytail17
    Member
    Posted 6 months ago #

    @Andrew sorry you're right... I just thought that providing help in French (our mothertongue) on this thread would be unpolite to the other users but could also make it easier to understand/fix the issue...
    I obviously understand the need for the solution to be published on this thread so as to help all the users :D

  24. zoeromero
    Member
    Posted 6 months ago #

    thanks all for your help! @Fairytail17, French is not my mother tongue anyway : )), but thanks a lot anyway!

  25. Fairytail17
    Member
    Posted 6 months ago #

    Double mistake! That'll teach me! :P
    Hope you find a way to fix your issue!

Reply

You must log in to post.

About this Theme

About this Topic