WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed wp URL, now can't get to wp-admin (10 posts)

  1. Trindade
    Member
    Posted 7 years ago #

    I have an installation in ./blog - The site is up and running and it has been functioning perfectly well.

    I changed the URL to . as per this man page:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Now when I go to ./blog/wp-admin I get a "This page can not be found" error, but the page is clearly there. The rest of the content display is OK.

    I followed the steps from this guide to revert the change:
    http://www.tamba2.org.uk/wordpress/site-url/

    But nuh uh, no good. Still can't access wp-admin

    My wordpress version is v2.0.4

  2. Samuel B
    moderator
    Posted 7 years ago #

  3. vkaryl
    Member
    Posted 7 years ago #

    Yah, Sam, he noted he'd done that. I dunno....

  4. Trindade
    Member
    Posted 7 years ago #

    Hmm. I note some other users having the same problem:
    http://wordpress.org/support/topic/91762?replies=3

    Perhaps this is a bug with 2.0.4?

  5. Trindade
    Member
    Posted 7 years ago #

    Also I deleted the cache directory (though I have caching disabled so it was empty).

    Still no dice.

  6. Trindade
    Member
    Posted 7 years ago #

    I rolled back my database to a snapshot from last night before I made any changes. There's still no access to wp-admin.

    I've undone the change I made to index.php, it's still no good. There's something in the html files which must have been changed when I updated through the admin interface.

  7. Trindade
    Member
    Posted 7 years ago #

    I'm pulling out my hair.

    I restored my files from snapshot and it's still all screwed up.

  8. Starkmann
    Member
    Posted 7 years ago #

    I killed my blog accidentally today in a very similar way.

    I ended up deleting the old install. Opened a new database. I installed clean and pointing to the new database. Then I redirected the program to my old database.
    It was probably reckless but it worked.
    It may work for you.

    DISCLAIMER: you follow this at your own peril.

  9. Trindade
    Member
    Posted 7 years ago #

    Wow.. that's awful. This is actually really crappy. I followed the manual exactly and end up in this situation.

    There has to be a way to correctly revert what was done.

  10. Trindade
    Member
    Posted 7 years ago #

    Ah. There was a cache with that snapshot. Cleared it, done.

    Still, there is -definitely- something changed in the php or html files by modifying that setting, and it should be documented somewhere.

Topic Closed

This topic has been closed to new replies.

About this Topic