WordPress.org

Ready to get started?Download WordPress

Forums

WP Document Revisions
[resolved] Changed upload path in multisite. Files show 404 (2 posts)

  1. neocreo
    Member
    Posted 5 months ago #

    Using this most excellent plugin for an extranet solution, but did a boo-boo.
    I had to change the upload folder from the standard
    /wp-content/uploads/
    To something more individual for the sites, so I decided to use the site_id function.
    /wp-content/uploads/%site_id%

    And now every single link to the documents break.
    I have tried updating the permalinks, download the upload directory (yes all files seem to have moved correctly to the right location), and now I am stomped. Seem like the attachment path haven't updated.

    Also tried uploading a new version to some test-files and that seem to adjust the attachment link. The permalink still points in the correct place like before the change
    www.mynetwork.com/subsite/documents/2014/02/somefile.doc
    For all the others it seem to be effed up though.

    Any help with this is mucho appreciated.

    https://wordpress.org/plugins/wp-document-revisions/

  2. neocreo
    Member
    Posted 5 months ago #

    Well, smack my bottom and call me Zoot.
    Feel very silly now. I had checked the location of the original files - missing the newly created folder in the root of the uploads folder. Of course I had to move all the uploaded documents via FTP to this new location.

    I hope someone else can learn from my foolishness.

Reply

You must log in to post.

About this Plugin

About this Topic