WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed Theme Name - Now WordPress Can't Find It (6 posts)

  1. kaboomer
    Member
    Posted 6 years ago #

    I just upgraded to WP2.5, and upgraded my theme from Mandigo 1.23 to 1.32. Everything worked great!

    However, I noticed that the theme folder on my server was still called "mandigo1.23". I changed that to "mandigo1.32"....and now WP can't find the theme at all.

    I've tried changing the name of the theme folder back to its former working self - no dice.

    Can anyone tell me how to fix my overzealous mistake? Thanks!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Don't do that. WordPress only knows of a theme by its folder name. If it can't find it, then it reverts to the default theme.

    Once you changed the folder name, WordPress reverted to default. Now you have to manually set it back to the correct theme.

    But first, change the folder name to just "mandigo". No version number. Then go and select the theme in WordPress.

  3. kaboomer
    Member
    Posted 6 years ago #

    Otto42, thanks for the reply.

    Unfortunately, selecting the theme in WP is precisely the problem here.

    When I go to the Dashboard and select Design/Themes, there are no options under Current Theme and Available Themes. So I can't select anything. This is the case no matter what I name my erstwhile 'mandigo1.23' folder.

    How do I get WP to "see" the mandigo folder again? Thoughts?

    Thanks! ~ MB

  4. kaboomer
    Member
    Posted 6 years ago #

    Interesting - I took the Classic and Default themes out of my trash, put them back in my WordPress folder...and now they and the Mandigo theme are selectable. Problem solved! Computers.....

  5. jazzle
    Member
    Posted 6 years ago #

    I usually delete the 'classic' theme and that doesn't cause any problems.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The default theme is required, you can't remove it.

    Any other themes are optional.

Topic Closed

This topic has been closed to new replies.

About this Topic