WordPress.org

Ready to get started?Download WordPress

Forums

Changed the WordPress address now lost template and login ability (12 posts)

  1. wpwendy
    Member
    Posted 5 years ago #

    Hi, I went to work on my wordpress site and.... listened to some bad advice and ended up trying to change the path in admin. in order to have text appear on the 1st page of my static blog.

    So, now I lost the template and can't log in to admin. I upgraded to the latest version, I tried to restore old files and database, nothing works -I'm locked out. Site appears but no template and I can't log in.

    I was in admin section trying to change the path of the home page. Anyone know what file I need to modify or what I have to do to get this to work?

    Thanks.

  2. whooami
    Member
    Posted 5 years ago #

    The correct way to move wordpress is here.:

    http://codex.wordpress.org/Moving_WordPress

    the directions for undoing what you have done are here:

    http://codex.wordpress.org/Changing_The_Site_URL

  3. wpwendy
    Member
    Posted 5 years ago #

    Perhaps I was not clear - I was not moving WordPress. I made my WordPress site into a static wordpress web site. I was not getting any content on the 1st page after I upgraded to 2.6. I went to fix this problem, but ended up going to the "Settings" tab and by mistake I renamed the path. WordPress address (URL) and/or Blog address (URL)
    I have done restores from backups, uploaded the new 2.6 something, but I can't seem to find the place to change the address back.

    When I saw this error, I put in "./the-auction-specialist/wp-blog-header.php" in the index.php file, but it didn't work.

    Below is the error message I get when I go to the site htpp:/the-auction-specialist.com

    Warning: main(./the-auction-specialist/wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/auction/public_html/index.php on line 17

    Warning: main(./the-auction-specialist/wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/auction/public_html/index.php on line 17

    Fatal error: main() [function.require]: Failed opening required './the-auction-specialist/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/auction/public_html/index.php on line 17

    and when I go to http://the-auction.specialist.com/wp-admin I get:
    but not sure how to change this to what?

    Do I go into index.php and change line to what exactly? There was no line 17...
    Do I go into wp-includes and change what exactly on line 43?
    Do I need to change something in the database?

    Thanks, error message below

    Warning: main(/home/auction/public_html//wp-includes/classes.php) [function.main]: failed to open stream: No such file or directory in /home/auction/public_html/wp-load.php on line 43

    Fatal error: main() [function.require]: Failed opening required '/home/auction/public_html//wp-includes/classes.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/auction/public_html/wp-load.php on line 43

  4. whooami
    Member
    Posted 5 years ago #

    I was not moving WordPress.

    yes you were/are but im not going to argue the point -- a variation of what you are/were trying to do is listed on that page.

    undoing what you did was simple had you read the second link before messing with more things. Once that was done, you could have followed the directions in the first link.

    ...but I can't seem to find the place to change the address back.

    Again, I already provided a link to those instructions

  5. wpwendy
    Member
    Posted 5 years ago #

    I restated the question, whatever I did was before I came here for advice.
    I understand the ambiguity of the term "moving" but it was unclear to me at first.

    My question is this now:
    1. I tried changing the above as per the instructions.

    I added the two lines to the functions.php theme file - no help

    In the wp-config.com file, there are many places that use the word
    Define

    It is unclear to me why step 1 didn't work and where to put in define('RELOCATE',true) as there are many places in the config file which use the word define.

    I am not sure the exact url to log into after this task is done. By "wp-login.php" do they mean that literally or do they mean go to my url wp-admin? This is confusing me a bit.

    Edit the wp-config.php file.
    After the "define" statements, add this new one:
    define('RELOCATE',true);
    Go to the wp-login.php page in a web browser.
    Login as per normal --

    When the RELOCATE flag is set to true, the siteurl (NOT the home setting) will be automatically updated to whatever path you are using to access the login screen. This will get the admin section up and running on the new URL, but it will not correct any other part of the setup. Those you will still need to alter manually.

    You should remove the additional line after the site is up....

    Is there someone who can help me reinstate my site?
    How would I contact them?
    Thanks

  6. whooami
    Member
    Posted 5 years ago #

    I can help you, just email me off the forum. village-idiot.org @ whoo (reverse those, whoo needs to go in front). Im off work though in 50 minutes .. so if youre not speedy, you'll have to wait till i get home, which will be about 8am my time (CST), by the time I stop and get coffee.

    its actually very easy to fix, but easier to do when you can see the files.

  7. wpwendy
    Member
    Posted 5 years ago #

    Thanks so much - I just emailed you. I have full backups of everything...

  8. whooami
    Member
    Posted 5 years ago #

    im leaving work right this second :( -- expect it to be about an hour before you hear back. I really need that coffee, sorry, I work 12 hour shifts.

  9. wpwendy
    Member
    Posted 5 years ago #

    I'm thankful for any help. I'll email you.

  10. wpwendy
    Member
    Posted 5 years ago #

    I'm teaching a class today until 2pm, so I won't be here in an hour. I'm hoping to catch up with you when you are available. I emailed you... Thanks, I appreciate it.

  11. matteoraggi
    Member
    Posted 5 years ago #

  12. momunplugged
    Member
    Posted 4 years ago #

    This happened to me too.

    Whooami's link: http://codex.wordpress.org/Changing_The_Site_URL worked for me. (Used the "Quick Fix Method")

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic