WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed site URL, now can't login?? (20 posts)

  1. BCeen
    Member
    Posted 3 years ago #

    I have just had my hosting company change the url of my site from http://www.mysite.co.uk/mysite to ww.mysite.co.uk

    These both point to the same directory.

    Unfortunately now site is not working correctly, the site simply displays the plain text without the them or styling.

    Also I am unable to login to the dashboard.
    I have tried the existing login
    http://www.mysite.co.uk/mysite/wp-login.php This just redirects to the home page

    http://www.mysite.co.uk/wp-login.php gives me the login boxes but after that just diverts to the homepage aswell.

    I can access all the files via ftp as these have not changed location.

    I've been told it's simply a question of redirecting the files urls's??

    Any help is hugely appreciated

    Ben

  2. govpatel
    Member
    Posted 3 years ago #

    Since you changed the url and if you want it that way then you will have to move your contents of your wordpress folder in root for it work.

  3. BCeen
    Member
    Posted 3 years ago #

    Thanks, but the hosting company set it up so both these URL's point to the same root folder. This is not located at http://www.mysite.co.uk/mysite

  4. govpatel
    Member
    Posted 3 years ago #

    Where are your wordpress folders and files you can post your url here we can see to guide you.

  5. BCeen
    Member
    Posted 3 years ago #

  6. I have just had my hosting company change the url of my site from http://www.mysite.co.uk/mysite to ww.mysite.co.uk

    When you move WordPress, you have to do a couple things.

    1) Change the Blog and Site URLs
    2) Move the files

    Have you read http://codex.wordpress.org/Moving_WordPress

  7. govpatel
    Member
    Posted 3 years ago #

    try and switching to default twenty ten theme and see if you still have problem to rule theme problem.

  8. BCeen
    Member
    Posted 3 years ago #

    Re ipstenu:
    Thanks I've read the help page but it dosen't seem to answer my problems.
    1). I can't access the dashboard how else can i do this?
    2). Both these url's point to the same root folder, they're pulling in the content just not the theme.

    Re govpatel:
    Thanks, any idea how I could do this when it will not allow me to access the dashboard?

  9. Roy
    Member
    Posted 3 years ago #

    Change the url back
    http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database
    (and read the rest of that article too).

    Then follow Ipstenu's link to move WP correctly.

  10. govpatel
    Member
    Posted 3 years ago #

    I am just unclear on exactly where your wordpress files and folders are they in root that is http://www.coastalpaths.co.uk/ (public_html if you using cpanel)
    or are they in folder
    coastalpathswalkingholidays

    and what are urls that are in Settings General
    Since you can not log in admin that tells me that your urls are not set right and if they are

    you can switch to default theme by logging in ftp and rename the theme you using and go to your website that force wordpress to open default twenty ten theme to open.

  11. BCeen
    Member
    Posted 3 years ago #

    Fixed it. Thanks for all your help.

    I pasted the following into the wp-config.php

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

  12. govpatel
    Member
    Posted 3 years ago #

    Since you put in wp-config.php you will not be change that in Settings General any more will grayed out

  13. simon93a
    Member
    Posted 3 years ago #

    Interesting reading the above problem and solution. It worked for me too. Basically, I set up my site without the www and wanted to change it so that it had the www before the url. When I did that, i was unable to log back in because the admin url kept redirecting to the new www which wouldn't allow access. I resolved the issue by adding the below code to the wp-config.php page:
    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    So, now as govpatel has rightly indicated, I am now unable to adjust the url in the dashboard settings (it is greyed out).

    Does anyone know the correct process for changing the URL (making it http://www.yoursite when it was set up as simply http://yoursite
    ?

    Thanks in advance

  14. glutenfreerecipebox
    Member
    Posted 3 years ago #

    Adding the 2 lines worked like a charm! Thank you so much Bceen!

  15. govpatel
    Member
    Posted 3 years ago #

    Take them two lines out of wp-config.php if do not want them grayed out

    Does anyone know the correct process for changing the URL (making it http://www.yoursite when it was set up as simply http://yoursite
    ?

    I think mod_rewrite converts http://www.yoursite to http://yoursite

    My videos will show you how to.

  16. glutenfreerecipebox
    Member
    Posted 3 years ago #

    I took the code out and could not access the admin page again. I read that you need to place it in your function.php file and that gave me access to the admin page. I then deleted those 2 lines as suggested. But now I am still having trouble accessing other pages. What I originally did is changed the name of the url to "shop.mydomain.com" I do not use "www". Now certain pages are looking for the server at (http://shop.gluten-free-gift-baskets.com)" instead of (http://gluten-free-gift-baskets.com). I am only having trouble with some of the pages that are listed within the WP eCommerce plugin. I am using WordPress HTTPS plugin which enables me to force pages I have created to https, but the product pages and my "shop" pages that are automatically created by WP eCommerce are the ones that are still trying to locate the "shop.mydomain.com".

    Any help is appreciated.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Any of the ways listed here will do the trick:
    http://codex.wordpress.org/Changing_The_Site_URL

  18. glutenfreerecipebox
    Member
    Posted 3 years ago #

    I did the function.php change and it worked, but I was advised not to keep that code in there. Once I took it out, the few pages from the eCommerce site that should be https are getting the errors. Is it safe to leave those lines in the function.php file?

    Thanks for your fast reply!

    Carla

  19. glutenfreerecipebox
    Member
    Posted 3 years ago #

    I added those 2 lines back in the function.php file and it still will correct the pages that were getting errors. Any other suggestions?

  20. glutenfreerecipebox
    Member
    Posted 3 years ago #

    All fixed now! Simple fix. I just need to go to the Admin tab in WordPress HTTPS and click at the bottom of the page, "Update Page urls". I also clicked, "Fix Product Group Permalinks". One or both of those fixed the problem. I now deleted the code in the function file and I still have access to my WP admin page.

    Thanks again for all of your help. Now I can go to sleep peacefully!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.