WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed site url and now can't access admin panel?! (11 posts)

  1. hemustincrease
    Member
    Posted 3 years ago #

    Hi,

    I'm new to wordpress. I'm hosting it on Godaddy.

    I was just trying out some new themes and finally decided on one of the free ones on offer from within the wordpress installation.

    I then tried making some changes to various settings, like uploading a header and changing the title of the site etc.

    I then noticed that my site url was: http://hemustincrease.com and I didn't know why it was missing the www part. I therefore went ahead and changed it to be http://www.hemustincrease.com instead.

    As soon as I clicked save I could no longer access my site or admin panel.

    Having said that I now get a strangely formatted login screen when I go to:

    http://hemustincrease.com/wp-login.php

    but it doesn't accept my Godaddy hosting username and password. Would my WordPress username and password be different from my Godaddy one? I don't remember setting up a separate one for WordPress?

    Thanks in advance for your help.

    Phil

  2. holliday22
    Member
    Posted 3 years ago #

    The WordPress username & pw would be different than your Godaddy Hosting unless you specifically made them the same.

  3. There's no default connection between GoDaddy logins/passwords and your WordPress install.

    You need to see Changing The Site URL « WordPress Codex for site recovery instructions.

  4. Go Daddy
    Go Daddy Support
    Posted 3 years ago #

    Hey Phil,

    @songdogtech is absolutely right. You have full control of what was created for your WordPress login. Your Go Daddy account will not have any bearing on this.

    That is a great link too! Did this help you? Let us know if we can provide any other info.

    ^Trevor

  5. hemustincrease
    Member
    Posted 3 years ago #

    Thanks for the help. Any idea which method I should use from that link? They all look quite complicated and seem to be for different scenarios?

    Did this error occur because I did something wrong, or is it just a problem with the software?

    One final question :-)

    Should I have changed my blog url to include the www part or was that where I went wrong? I don't understand why everwhere seems to omit the www part, but maybe that gets added in automatically somehow?

    Thanks again for your help.

    Phil

  6. Any idea which method I should use from that link?

    Use the phpMyAdmin method. As you mentioned, they're all a bit complicated, particularly the phpMyAdmin method, but it's the most sure-fire way to fix the problem.

    Did this error occur because I did something wrong, or is it just a problem with the software?

    This doesn't happen often. I imagine that there could have been a typo when you changed the domain.

    Should I have changed my blog url to include the www part or was that where I went wrong? I don't understand why everwhere seems to omit the www part, but maybe that gets added in automatically somehow?

    www is pretty much useless these days. I wouldn't worry about it.

  7. hemustincrease
    Member
    Posted 3 years ago #

    Wow thanks James for the quick reply.

    So it should be ok for me to change it to use the www part though - right?

    I know it doesn't do much but the site has always had the www part there so I would like it there as long as it's supported by WordPress, if that makes sense?

    Thanks,

    Phil

  8. Wow thanks James for the quick reply.

    You're welcome!

    So it should be ok for me to change it to use the www part though - right?

    Yes, that should be perfectly fine.

  9. hemustincrease
    Member
    Posted 3 years ago #

    Great. I've followed those steps and got my site back up and running, by changing the url to not include the www part.

    The only step I couldn't follow was:

    Delete the folder wp-content/cache (this is a new folder added with WordPress 2.0).

    Any idea if it matters that I couldn't find this folder to delete? If so, do you know how I can find that folder?

    Finally, there wasn't a typo in my url when I had the www part included so i'm not sure what was going wrong. I guess maybe I need to check my domain settings in Godaddy to see if something is set up for www not to work but without www to work fine?

    Thanks,

    Phil

  10. If you couldn't find a cache directory, then there's no reason to worry about it.

    You should definitely check with GoDaddy regarding the www discrepancy.

  11. Go Daddy
    Go Daddy Support
    Posted 3 years ago #

    Hi Phil

    Glad to hear you got things up and running again.

    If the domain was updated in your WordPress administrative site, it's possible it did not get updated in your database when you added the 'www' to it. This would have caused the types of errors you outlined earlier. Should you need to change the domain again, you can confirm it has been updated by going to phpMyAdmin for your database, visiting 'wp_options' then updating the URL by editing the 'siteurl' row in the option_value field. Details can be found here: http://go.me/KP

    Hope this helps clear things up!

    ^Trevor

Topic Closed

This topic has been closed to new replies.

About this Topic