WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] changed servers, existing permalink structure doesn't worl (8 posts)

  1. thedayofgames
    Member
    Posted 4 years ago #

    I switched from Network Solutions to a private server.

    Everything works when I change my permalinks to "Default".

    But all of my posts are currently cataloged through Google under their old Permalink structure. Why didn't this transfer properly?

    I have tried to swtich away from Default but it blows up.

    I have pasted that code into the htaccess file and then uploaded to the server but that doenst change anything. How specifically should I edit and upload the htaccess?

    Any ideas?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Did you edit the .htaccess file in a plain text editor? Did you upload the amended file in ASCII mode? Where did you upload this file to? Have you tried uploading an empty .htaccess file (in ASCII mode) to your root WP folder and ensuring that it is writable?

  3. thedayofgames
    Member
    Posted 4 years ago #

    Did you edit the .htaccess file in a plain text editor?
    I just used Notedpad which is the only program I could find that would open the .htaccess file. Is there something else I should use?

    Did you upload the amended file in ASCII mode?
    Not sure what that means. I uploaded the amended .htaccess file to the server just like I uploaded the rest of the folders - via Dreamweaver.

    Where did you upload this file to?
    There was an existing .htaccess file within the main folder, so I simply opened that file and edited it, then re-uploaded to the same location.

    Have you tried uploading an empty .htaccess file (in ASCII mode) to your root WP folder and ensuring that it is writable?
    I don't think my .htaccess is writable because WordPress tells me it isn't when I try to change permalink structure. What is ASCII mode?

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    What is ASCII mode?

    A plain text upload as opposed to a binary upload for zips, exe files etc. Check to see if Dreamweaver is configured to use an auto upload mode (ie it changes upload mode automatically based on file type). If it is, make sure that .htaccess is added to its list of text/ASCII file types.

  5. thedayofgames
    Member
    Posted 4 years ago #

    After Googling around it looks like maybe Dreamweaver doesn't upload the .htaccess file to the server. I will need to check with the tech people managing my server to see if it is there.

    Is my method for entering the text correct? Just copy and paste what WordPress tells me to?

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Yes - your method is correct. Perhaps you could install an FTP client. It will make your life easier long-term.

  7. thedayofgames
    Member
    Posted 4 years ago #

    So I have now physically dragged the htacces file over into blog folder and the permalink structure is still not working. What is my issue??

    Is there any way to troubleshoot this item and see where the errors are?

    Within the Admin area of the Permalinks sections it still says -
    "You should update your .htaccess now."

    I have already pasted this code into the htaccess file and it is now on the server. Still not working.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dogblog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /dogblog/index.php [L]
    </IfModule>

  8. thedayofgames
    Member
    Posted 4 years ago #

    RESOLVED - by updating the permissions of htaccess and index. and then

    Modify the Permalink code to "Custom" and add /index.php/ to the front

    ----------------------------------------------------------------
    If this isn't an option, you can try PATHINFO permalinks; put index.php/ at the start of your custom permalink structure:

    /index.php/%year%/%monthnum%/%day%/%postname%/
    --------------------------------------------------------------------

Topic Closed

This topic has been closed to new replies.

About this Topic