WordPress.org

Ready to get started?Download WordPress

Forums

Changed Permalinks now Parent not working (9 posts)

  1. ajia.im
    Member
    Posted 6 months ago #

    I'm trying to fix the website below and I changed the Permalinks from Default to Post-Name.

    http://rejuvenex.victradeshall.com

    Now all the pages that have Treatments as a Parent in page attributes are not found when i visit their direct link.
    However, when i set the Permalinks back to default they start working again.

    For example:
    http://rejuvenex.victradeshall.com/service/body/

    Can someone please help me with what changes I need to make?

    This is the treatment.php file if you need it:
    https://www.dropbox.com/sh/v5ide3zkriw04z5/zBjvg3vHtP/treatment.php

    Many thanks in advance! This is killing me... :(

  2. esmi
    Forum Moderator
    Posted 6 months ago #

    Check with your hosts that mod_rewrite is running on your server.

  3. ajia.im
    Member
    Posted 6 months ago #

    I confirmed that mod_rewrite is running on my server.
    What are the next steps?

  4. ajia.im
    Member
    Posted 6 months ago #

    Just to let you know the page has now moved to:
    http://victradeshall.com/rejuvenex/

    and example of the page not working is:
    http://rejuvenex.victradeshall.com/service/body

  5. Forensica Digital
    Member
    Posted 6 months ago #

    Check this out: http://codex.wordpress.org/Moving_WordPress

    Basically:

    Log in to your site.

    Go to the Administration > Settings > General panel.

    In the box for WordPress address (URI): change the address to the new location of your main WordPress core files.

    In the box for Site address (URL): change the address to the new location, which should match the WordPress (your public site) address (URI).

    Click Save Changes.

  6. ajia.im
    Member
    Posted 6 months ago #

    I've tried that already. No luck :(

  7. ajia.im
    Member
    Posted 6 months ago #

    It's just the below links on the main page that are having the issue.
    - Face
    - Skin
    - Body
    - Health

    Everything else is working fine.

  8. Forensica Digital
    Member
    Posted 6 months ago #

    Is there a possibility that those links are in a custom code block? or maybe they are pointing (if made with a widget) to an external url (your old url).

  9. ajia.im
    Member
    Posted 6 months ago #

    There might be something to do with these widget?
    I don't really understand what their doing to be honest. But I'm assuming the page ID is still the same so it shouldn't break the links?

    Sidebar Widget:
    https://dl.dropboxusercontent.com/u/47731225/widget.jpg

    Here are the plugins:
    https://dl.dropboxusercontent.com/u/47731225/plugins.JPG

Reply

You must log in to post.

About this Topic