WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Changed permalinks. Now getting a "500 Internal Server Error" (8 posts)

  1. SLeece
    Member
    Posted 2 years ago #

    Help!

    I changed the permalinks on my blog (blog.nestcreative.ca) and now I am getting a "500 Internal Server Error".

    I've tried reviewing a few posts in the forums and they keep referring back to a web.config file. I downloaded this file and this is what is currently in the file:

    "<?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name=”wordpress” patternSyntax=”Wildcard”>

    <match url=”*” />

    <conditions>

    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />

    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />

    </conditions>

    <action type=”Rewrite” url=”index.php” />

    </rule></rules>
    </rewrite>
    </system.webServer>
    </configuration>"

    I have no idea what else to do here :( Any help is greatly appreciated.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Please contact your host, as it seems your site is disabled. See this report.

  3. SLeece
    Member
    Posted 2 years ago #

    So I contacted GoDaddy, but I'm impatient so I kept looking for answers. I found this post from GoDaddy, followed the directions, and now my site is working again. Very weird...

  4. SLeece
    Member
    Posted 2 years ago #

    Ok...nevermind...

    It worked briefly and now it's just posting a page with more info about the error...of course I understand none of this information :(

    Anyone? Please?

  5. Will D. White
    Member
    Posted 2 years ago #

    If you have a backup of the web.config file, go ahead and load it back up. Most wordpress installations will manage their permalink settings through a file called .htaccess.

    There are a variety of ways to check that your htaccess is set up correctly. In FTP, ensure that hidden files are being displayed (usually in the view tab) and download a copy of the .htaccess file.

    Make sure that it has a section that looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    If it looks different, put that in at the top of the file and save it and put it back on the server.

  6. SLeece
    Member
    Posted 2 years ago #

    Sorry, I don't understand much about this stuff yet. I don't think I have a .htaccess file, because I'm on a Windows server (apparently my first mistake). I believe that I have a web.config file instead.
    Feel free to correct me if I'm wrong, because that's entirely possible :D

  7. SLeece
    Member
    Posted 2 years ago #

    I got a response back from GoDaddy:

    "... The issue appears to be due to the scripting set up within your web.config file, particularly the section regarding a WildCard(*) entry. Please keep in mind that wildcard entries will not work with your hosting account at this time, as you have a shared IP Address..."

    This makes no sense. My web.config file for both http://www.nestcreative.ca and for my subdomain test.nestcreative.ca, includes the previously mentioned wildcard entry. Both are operating just fine.

    I tried copying the web.config file for http://www.nestcreative.ca to the subdomain, and it's gone back to giving me a "500 Internal Server Error".

    :(

  8. SLeece
    Member
    Posted 2 years ago #

    Ok, just deleted my web.config file from that subdomain (after noticing that another subdomain didn't have one) and it's working.

    Not sure if that was a good idea, but I guess I'll find out. Might be something to try (provided that wasn't the dumbest thing ever) if anyone else is having the same issue. :)

Topic Closed

This topic has been closed to new replies.

About this Topic